KDE : minimized programs not showing in taskbar

i don’t know what happened but when i booted into my computer today … my kde taskbar is not showing me the minimized programs …
any solutions ?

Are the desktop effects disabled?
Is the Compositor disabled?

If one of the above is yes, then re-enable one or both.

1 Like

my bad mate … i found the solution … i accidentally removed the task bar widget

thanks for sparing your time though

Okay, so first you need to setup a clean build environment and grab all the compile tools from the official software repositories, including git.

What we’re going to do is compile the latest Plasma and kde-framework from source and apply a patch from March 22 that’s still in the testing branch.

Steps 1 through 16 will be setting up your build environment. Steps 17 through 22 will involve compiling and patching the KDE libraries and the latest -dev version of the taskbar. Steps 23 through 30 will involve replacing the installed libraries and applications with everything from Steps 1 through 22, while making a backup of your current system to a remote cloud server. After which, we’ll reboot into your updated system, then test if this shows icons in your taskbar of minimized apps.

Alright, you ready? Here we go!

  1. pacman -S git gcc make
  2. mkdir $HOME/kde-patches
  3. cd $HOME/kde-patches
  4. git clo-, wait…

…or that.


Even if he did not removed by mistake his task bar widget, why the hell would you recommend to recompile the whole Plasma framework from source and applying a random patch?

Or was that some kind of a joke I didn’t get?

It was a joke. See the ironic smiley at the end of his post :slight_smile:

1 Like