KDE Launcher no longer displays hardly any installed apps

Today after a failed install of an AUR package (gmail-desktop-bin (3.0.0_alpha.37-4) almost all applications disappeared from KDE’s application launcher. The package failed to finish installing after electron 23 failed to build. I wasn’t too concerned about it, and I removed all of the packages that didn’t get cleaned up after the failed build.

After this, I noticed a few icons on my bottom panel were white, and I couldn’t even tell what they were anymore. I restarted the system, and the icons were still white. I decided to open the pamac GUI to see if I accidentally removed something that I shouldn’t have. But I couldn’t even find the pacmac GUI. Usually I start typing “software” in the app launcher, and it shows up, and I click it, but it was no longer in the list. In fact, almost EVERY app was missing. No Dolphin, no Brave Browser, only about 5 apps (one of them is KATE) were showing up. I opened a terminal and typed Dolphin, and Brave, and other apps, and they open from the terminal, so they aren’t missing. But the KDE launcher will not display them. To open the pamac GUI, I have to enter pamac-manager.

Anyway, I can’t figure out what happened, but somehow that failed build AUR install has royally messed up the KDE app launcher and it no longer sees my apps. I’ve restarted again, I reinstalled Brave browser, and no it’s icon shows up. But I don’t want to have to reinstall every app to get it show up again in KDE launcher. Is there a way to “refresh” or have the launcher rescan for my apps so they show up again? Below is a list of the dependencies installed by the gmail-desktop-bin package, which I uninstalled after the failed build (with the exception of Brave Browser which is in the list, which I didn’t uninstall)

[2023-09-14T15:29:05-0400] [ALPM] installed asar (3.2.4-1)
[2023-09-14T15:28:43-0400] [ALPM] installed electron23 (23.3.13-1)
[2023-09-14T15:26:40-0400] [ALPM] installed electron (1:25-1)
[2023-09-14T15:26:40-0400] [ALPM] upgraded brave-browser (1.57.62-1 → 1.57.64-1)
[2023-09-14T13:42:55-0400] [ALPM] installed gendesk (1.0.9-3)
[2023-09-14T13:42:55-0400] [ALPM] installed lld (16.0.6-1)
[2023-09-14T13:42:55-0400] [ALPM] installed gn (0.2119.cc56a0f9-1)
[2023-09-14T13:42:55-0400] [ALPM] installed python-httplib2 (0.22.0-4)
[2023-09-14T13:42:55-0400] [ALPM] installed gperf (3.1-5)
[2023-09-14T13:42:55-0400] [ALPM] installed ninja (1.11.1-3)
[2023-09-14T13:42:41-0400] [ALPM] installed electron25 (25.6.0-1)
[2023-09-14T13:42:41-0400] [ALPM] installed nvm (0.39.5-1)

Here are my system specs:

Operating System: Manjaro Linux
KDE Plasma Version: 5.27.7
KDE Frameworks Version: 5.109.0
Qt Version: 5.15.10
Kernel Version: 6.1.51-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × AMD Ryzen 5 5625U with Radeon Graphics
Memory: 30.7 GiB of RAM
Graphics Processor: AMD Radeon Graphics

create a new test user, reboot, log in with it and see if it has the same issue…
if not, rename the following folders in your main user home directory:
.cache. to .cache.bak
.config to .config.bak
reboot and see if it helped

Same issue with new user.

I was going to suggest

kbuildsycoca5 --noincremental

and/or the whole dance outlined here:

But … if it exists with a new user as well then its something ‘deeper’ than user/home config.

Though, I might try it anyways
(but be aware if you follow all of the steps on the wiki you will lose desktop configuration)

Sounds silly … but maybe also try removing and adding back the launcher widget.

To be sure the applications arent missing you can check installed packaged with, ex:

pacman -Qs dolphin

All packages are definitely still there, pacman -Qs shows them, the pamac gui shows them, and all apps still start if I run them from the shell. They just don’t show up in the launcher, even if I type their name. It’s very strange.

I have also tried using other launchers other than the default. The issue is the same with all launchers.

If I open the pamac-manager gui, and select an installed app, and click the “launch” button, the apps won’t even launch from there, even though it shows installed. Instead, in the terminal I see a message saying gtk-launch no such application firefox.desktop or whatever the app name is. And it’s always suffixed by .desktop Is there a location where .desktop files are placed when apps are installed or something, and maybe some this got deleted?

Maybe try:

update-desktop-database ~/.local/share/applications -v
sudo update-desktop-database /usr/share/applications -v

(note: the second command will likely return a number of KDE apps lacking MimeType, which is fine)

So going off of this, we could also look …

ls /usr/share/applications

That was it! Thank you so much to point me there! My applications folder only had a few apps in it, but I noticed there was an applications.old folder with all my apps in it! So I renamed applications => applications.bak, and renamed applications.old => applications and restarted and everything is back!!

Wow, that gmail-desktop AUR package install is dangerous (or one of it’s dependents, I haven’t actually examined the build-files). It must temporarily rename the applications folder or something, and since the build failed, it didn’t clean up after itself and rename it back or something like that? Because I certainly didn’t rename it. Anyway, thank you so much for pointing me in that direction. Greatly appreciate it!

Ah, good find.
I guess I’m off to go look at that PKGBUILD … :face_with_monocle:

The issue might be the electron 23 package. That was where the build failure occurred.

It looks like it happens when it detects a preinstallation. Here is an excerpt from the installer log.

Warning: gmail-desktop-bin: /usr/share/applications already exists in filesystem It has been backed up to /usr/share/applications.old

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.