KDE: Is there a way to disable Keyboard Layouts?

For certain reason I use IBus. I just removed layouts from Keyboard Layouts, also disabled shortcuts. It works, essentially, but sometimes shows odd signs of afterlife, like its own labels. Is there a way to disable Keyboard Layouts cleanly?

My IBus settings:

  • Install IBus: $ yay -S ibus

  • Create ~/.config/autostart/ibus.sh (to be added to System Settings > Startup and Shutdown > Autostart > Script File):

#!/usr/bin/env bash
exec ibus-daemon -drxR



Hi @Llama ,


Here you have to sections: Shorcuts and Custom Shorcuts, you can add or remove them whether you are able either to unmark one Shorcut or add a new one.

You can also reach there with:

System Settings
Look for Shorcuts.

Hope this help, regards.

I already removed shortcuts, see the first line of my post. It sure clears the way for IBus, but the native Keyboard Layouts is somehow aware of the IBus activities and sometimes shows its own layout labels. Correctly, but I still prefer it just to hush :smile: