KDE Hibernate confirmation dialog not working

I am using KDE plasma. My hibernate function working fine and save in the swap partition. But when I click Hibernate from the menu button it doesn’t show any confirmation dialog. Confirmation dialog works for other options(reboot, shutdown, etc). In confirmation dialog, it has a hibernate entry but it doesn’t trigger when I click hibernate menu.

How can I enable confirmation dialog for hibernate option?

OS: Manjaro Linux x86_64 
Host: XPS 13 9370 
Kernel: 5.12.19-1-MANJARO 
DE: Plasma 5.22.4 
WM: KWin
1 Like

Thanks for the reply.
Yes, these settings are already checked but have no effect on hibernation.

  • Set them to something else
  • apply
  • set them back


1 Like


Maybe I’m misunderstanding your issue. Can you describe your issue differently?


1 Like

Yup, here is my problem.
This is my Leave menu:

If I click any item from the menu, it shows this confirm dialog with 30s timer:

But the only item that doesn’t work is Hibernate
When I click hibernate, it directly initiates the hibernation process without any confirmation.
From the confirmation dialog, I can see there is a hibernate option but it was not called during the click event.
This confirmation is important for me because sometimes I wrongly click hibernate option and it directly goes to hibernation and I have to wait to start again.

I have checked this file from breeze theme:
but coudn’t find any hibernateRequested() method call for the menu item.

Ah! That is by design!

If you want to hibernate, you want it right now, just before your battery runs out.

I think you’re in for a feature request over at the KDE developers!

  • File a bug
  • Take the correct application
  • Set the severity to Wish list


1 Like

Opps, thanks for the information.

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.