KDE doesn't recognize monitor

Hello everybody,

i had a strange issue. I tried to use an 21:9 3440x1440p monitor with manjaro, and didn’t get it to work. GRUB got displayed (horrendously, but still) but i got no picture whatsoever from Manjaro. I’m using KDE and an AMD R9 280X, connect with HDMI, as this was all i have right now. I’m sending the monitor back for other issues, but as i still want the new format i already ordered another one.

Windows was able to display on that monitor, but just with 50Hz, as HDMI 1.4 doesn’t seem to support more than that in that resolution. Could it be, that Manjaro tried to apply 60Hz and therefore no image was displayed? That would maybe explain it, but it would be weird and not really thought out, as i guess it would be better to default to a lower resolution then, to get at least any picture. I wasn’t using any dual monitor setup or something, just the 21:9 one.

As i will have to face that issue again in a few days, a few suggestions would be nice. When looking for answers i found primarily multi monitor setups, but no issues with single monitor ones.

This is really strange. My best guess is that this is actually a problem with your installation of Manjaro, if when you boot the device (I’m assuming you have a dual boot setup with Windows and Manjaro) it entirely skips the Manjaro boot manager and goes straight to Grub.

If it was a problem with the GPU wiring (and the monitor is plugged into the GPU) then the screen would simply not turn on.

If it was a Hz compatibility issue, the display would show a message stating the refresh rate was out of sync, or just disconnect and turn black. (And you can read on the compatibility of HDMI 1.4 and a 21:9 ratio here: https://www.reddit.com/r/ultrawidemasterrace/comments/571wpc/hdmi_14a_and_219_ratio_support)

If your system boots to Grub and skips the Manjaro boot manager, that probably means something about the boot manager is having a problem, and I sadly do not know how to fix that. Although, still assuming your pc is a dual-boot setup, did you just switch to windows using BIOS?

Hopefully that gives you some more info on your problem. I don’t know much about AMD GPUs, but maybe someone with experience in this topic could help you farther. I would recommend going to your bios and making sure that everything is looking good there for now, just to make sure you aren’t accidentally booting to something incorrect. Also, while you are in BIOS, don’t forget to make sure safe mode is disabled, as that is known to cause problems with booting Manjaro.

Hope this helps!

Thank you very much for your answer :slight_smile:

Yes, you guessed right, it is a dual boot config. Normally everythings fine, the other monitor works flawlessly, therefore i’m not sure it has something to do with the bootloader, but who knows.

Tahnk you very much for clarification on the other posible causes. My BIOS should be set up correctly, as i use manjaro now for a while, safe mode disabled etc. right boot device.

I didn’t mention it in the original post, but booting into windows from Grub worked without any problems. So hm. The new monitor should arrive on friday or monday, so i will try then again.

Okay, here my update: Everything works fine.

It may be, that the monitor runs now through Displayport, not HDMI, also the Display was firstly connected as a secondary monitor, and just after that as the single one.

So i don’t know, what the problem was with the old one. I’m sorry.

Glad it got fixed for you! I don’t know why the display port connection would be any different then the HDMI connection, unless they were physically wired differently, but I’m glad DisplayPort works.

Also, just a reminder, don’t forget to mark a solution once your post is solved!

(Sorry for the late reply)


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.