KDE DM not loading on fresh install


I have tried installing Manjaro 20.2.1-210103 and 20.2-210207 with KDE to a Dell 7060. The install for both goes fine but when I reboot I see the Dell splash screen and then the monitor goes black and in to power-save mode. It initially seemed like the OS wasn’t booting at all.

After some testing I realised that if I typed my password after the monitor went into power-save mode I would be able to log in and the KDE desktop would appear, even though I never saw the log in screen. I also found that if it pressed Ctrl-Alt-F2 after the screen went into power-save made I would get a terminal prompt where I was able log in and run the DM with the startx command. This happened with both versions of the ISO I tried.

I can see some others with a similar issue with Gnome on Manjaro but this doesn’t seem to be fully resolved.

Can anyone assist with determining why the DM isn’t running when the system boots?


Having plugged a second monitor into my desktop, I still have the same issue but I now notice that sddm-greeter appears once I have logged in as shown in the screen cap. I can close this and continue with my work but just adds to the annoyance I would ideally like to resolve. I have not had similar issues with other distros on the computer like Kubuntu.