KDE Desktop Cannot Change Screen Brightness

As the title shows, the monitor of my laptop only works at max brightness under KDE. I have read many articles include the Arch wiki and configured some grub files, but none of them helped. Commands like inxi -G returns the following:

Graphics:  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia v: 470.63.01 
           Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
           Display: x11 server: X.Org 1.20.13 driver: loaded: nvidia resolution: 1920x1080~165Hz 
           OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2 v: 4.6.0 NVIDIA 470.63.01 

I have also tried xbacklight -set 50, it returned normally, but the actual brightness of the screen is not changed. I also tried echo 50 > /sys/class/backlight/nvidia_0/brightness, it also returned normally but without changing the brightness.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. What is the output of:

    cat /sys/class/backlight/nvidia_0/*


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time