KDE Dbus Activity killing System Settings?


I got a new Manjaro KDE (wayland) Installation on my Dell Precision 5550.
It runs well, but i got some interesting behavior, that i think have something to do with Dbus.

I have to go to the Bluetooth settings everytime i boot, because Bluetooth doesnt activate automatically on launch. The setting is set to “Activate on startup”, but that doesnt work.

But this isnt the issue I’m posting about here.

Just after booting, System Settings do work fine.
I can see my connected bluetooth devices and Network connections.

But after a while, the Bluetooth settings just show “No Device Paired”. Connections ist just a blank window with a search box and the Thunderbolt settings are complaining about " Thunderbolt subsystem not available"

Network Connections and Bluetooth devices are still listed in the Taskbar, but not in System Settings anymore.

I suspect it has something to do with dBus.
When i add a CPU Activity widget to the Desktop, the error happens pretty quickly. This widget seems to send each update through Dbus.
(Same happens, when i open a system monitor for a while)

also sudo nmcli then just returns Error: Could not create NMClient object: Could not connect: Connection refused.

also an OpenVPN connection, that works fine when enabled quickly after boot, wont connect anymore once this “error” happens.

Any idea which logfiles i need to check?

A systemd base operating system - activates devices in arbitrary order - it is sometimes necessary to edit the bluetooth.conf to instruct the system to power up bluetooth on system start.

I suspect it could be power related - you are using a laptop system - right?

Can we assume that your system is fully synced using a current mirror for your system branch?

The system is theming sensitive - understood as - if you theme your desktop using a non maintained theme it may suddenly cause weird issues - especially for widgets - and everything on the Plasma desktop is a widget.

Can you eliminate the issue if you use the default Manjaro theming?


Thanks for the Reply!

Yes its a laptop system. Basically just the business version of a Dell XPS 15.

fully synced using a current mirror for your system branch

There are no updates available neither using pamac upgrade nor pacman -Syu if thats what you mean here.

I already tried adding AutoEnable=true to /etc/bluetooth/main.conf but that didnt to the trick either.

Apart from the stock Manjaro installation with an image I pulled last week, i just installed some applications. So no no theming done here.

Today I had my system running for about 10 hours. I didnt open System Monitor or have any widgets except for an analog Clock. Opened System Settings and everything looks fine.

Then while writing this post I opened System Monitor and after about 15 minutes, bluetooth just shows “No Devices Paired”, Connections is a blank screen with a search bar and Thunderbolt shows that the thunderbolt subsystem is not available.

Also I don’t know if thats related. The Shutdown, Reboot and so on Buttons in KDE dont work when the Settings break.
and sudo poweroff throws bus connection refused before going out.

This is probably just missing the packages:
bolt , plasma-thunderbolt

As to the rest … what do the devices look like:

inxi -NEazy


Both are already installed.

And as to the rest:

❯ inxi -NEazy
  Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:4 chip-ID: 8087:0026
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends

I was going to recommend the ol bluetooth coexistence setting for iwlwifi … but … it appears that setting is deprecated since kernel 5.8. :slightly_frowning_face:

Okay I just did a reboot and found a way to replicate it much quicker.

I just need to start VSCode with a Devcontainer. That confused me even more.
Maybe because the Devcontainer (docker-compose mode) spawns a virtual network in docker?
It doesnt happen for stacks that i start using docker-compose just the ones started through vscode.
And how could that impact thunderbolt or bluetooth?

And kernel wise. It defaulted to 6.1. I tried 6.3 but no change.