KDE Curved Screen Corner Problem

Hi, have a problem my there are weird grey box at the edges of my windows.
This also happens in other places, every time I take notes I can see it. Is there a way to fix this. This also happens if I right-click in applications. I know I’m very picky, but I just can’t sleep knowing there’s a grey box at the edge of each border.

Not sure if this is a Plasma KDE issue or Manjaro issue

System Information=
Operating System: Manjaro Linux
KDE Plasma Version: 5.22.3
KDE Frameworks Version: 5.84.0
Qt Version: 5.15.2
Kernel Version: 5.13.4-1-MANJARO (64-bit)
Graphics Platform: X11
DE: Plasma 5.22.3
WM: KWin
WM Theme: ChromeOS
Theme: Breeze Dark [Plasma], ChromeOS-dark [GTK2]
Icons: Tela-circle-dark [Plasma], Tela-circle-dark [GTK2/3]
Terminal: konsole
Uptime: 1 day, 23 hours, 50 mins
Packages: 1268 (pacman)
Shell: bash 5.1.8
Resolution: 1366x768
Terminal Font: xos4 Terminus 11
Processors: 4 × Intel® Core™ i5-2467M CPU @ 1.60GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 3000

Change the Window Decoration in settings to default Breeze …

1 Like

But that will change the look, it also does not fix the problem in the application

If that Window Decoration theme you use has rounded corners, then that is what will always be the case. On my end i have squared corners, and no artifacts.

Why does this happen? Is it a bug? Can I fix this without removibg this window decoration?

Now honestly … if that theme for Window Decoration has rounded corners, how do you want them to be straighten ?

You have two options…:

  1. Choose a different window decoration; or

  2. Disable the blur effect.

It’s a known problem with the kwin compositor when window decorations with rounded corners are used, and it has been around for a very long time already.

1 Like

Just a wild curiosity, KDE Plasma is implementing rounded corners in some of its own applications, then why these artifacts appear only when using not-preinstalled window-decorations?

No, it’s not. But GTK applications might have rounded corners because they are using client-side window decorations, which means that the window decoration is created and managed by the application itself, instead of by the window manager.

One of the big downsides of client-side decorations is that you will no longer be able to close the window if the application crashes, because the window management buttons for closing, maximizing and minimizing are all managed by the application itself.

The reason why GTK uses client-side decorations (where supported) is because GTK is the widget toolkit that GNOME is based upon, and GNOME looks toward macOS for inspiration ─ macOS also has client-side decorations. Furthermore, GNOME and GTK are both developed at RedHat, and often by the same people.


Thanks a lot for the clarification. :grin:

Disabling blur does work but It’s so hard to read text in panels and it just doesn’t look good. Can i atleast make my theme opaque instead of translucent. Changing the window decoration does not fix the problem in appication menus. I have this problem for almost 2 months now and im very impatient and i really care about it. Do kde team have any plans on fixing this?

Yes, Gtk application don’t follow qt stuff. Thats why I never use gtk apps on kde it looks so weird. So I don’t use pamac gui, I only ise cli.

Yes, but that is a matter of choosing an application theme. You must set that independently from the window decoration theme.

Well, I have just found a GTK theme that comes very close to my chosen Qt theme. I use the Glow Mojave Dark Kvantum theme and the matching Mojave Dark Aurorae window decorations, but I could not find any GTK themes that matched the look… until just now, that is…

I’m not sure where I got it ─ it might have come installed with an update or maybe I downloaded it a long time ago and forgot to take a look at it, but I’m now using a GTK theme called Gradient-black-325, and it matches the look very well.

I’ll attach two screenshots ─ the first one is Dolphin, a KDE-native Qt application, and the second one is Claws Mail, a GTK application that I use for monitoring the Usenet discussion groups.

Now I can’t sleep, I hadn’t realized that I have the same problem. And what I saw for the first time I can not stop watching …
You are very bad person :frowning:

1 Like

Sorry I guess, atleast the curved is way less curved than mine. Mine also happens in applications.

Ok this ia the problem with this, I don’t want to change the theme, I don’t want the blur boxed corners.

Option #3: Live with it.


Thats the neat part, I can’t…
I could try to use another DE but every DE I use just feels weird. Gnome doesn’t feel right, Cinamon reminds me of Windows 7, XFCE is too simple. Idk what to use? The only Gnome distro I came close to using was the stunning Zorin Os but it doesn’t have the AUR. I mean I could use cmake and compile the stuff myself but im too lazy.

Sheesh man, just get a different window decoration from store.kde.org. There’s a gazillion to choose from.


1 Like

Oh one more thing, there is a window decoration call lighthy shaders or smtg and it doesn’t get affected by this bug dispite having curved edges.