KDE connect Doesn't work since last update

I have an issue with KDE Connect since the last update. I am unable to pair my phone, since the PC doesn’t show up in the app. Tried unpairing and paring up again, but as you can guess, there is nothing to pair to from the phone.

PC doesn’t see the phone either.

Reinstalled the app in the phone. No change. I personally suspect that something’s wrong in the PC instance of KDE Connect, since it got updated.

How to troubleshoot and what kind of inxi output to post?

Edit: PC = laptop

I’ve just updated as well and KDE Connect is still connected to my phone.

Please ensure:

  1. Your PC and phone are on the same WiFi antenna (no range extenders, 4G, …)

  2. Is the kdeconnect process running:

    ps -ef | grep kdeconnect
    

    Example output:

    user 3399 1 0 08:26 ? 00:00:02 /usr/lib/x86_64-linux-gnu/libexec/kdeconnectd
    
  3. Is the process listening?

    sudo netstat -tunelp | grep -i kdeconnect
    

    Example output

    tcp6 0 0 :::1716 :::* LISTEN 1000 36999 3399/kdeconnectd
    udp6 39936 0 :::1716 :::* 1000 36998 3399/kdeconnectd
    
  4. Maybe your firewall gets in the way?

    • Turn it off
  5. Are the ports open/blocked?

    netcat -z -v <your-phones-ip> 1714-1764 # Try phone and laptop, use port which netstat shows
    

    Example output:

    Connection to <your -phones-ip> 1716 port [tcp/*] succeeded!
    (You also get lots of Connection refused, but you need 1 “succeeded”)

  6. Check the kdeconnect home dir

    ls -al /home/<user>/.config/kdeconnect/
    
  7. Check the CLI interface

    kdeconnect-cli
5 Likes

I do not have the KDE Connect, but separate outputs of the

$ journalctl --boot 0 --priority err --no-hostname

and

$ journalctl --boot 0 --no-hostname | grep "kdeconnect"

could be helpful also.

1 Like

Install it on both your phone and your PC: you’ll be amazed at what it can do!

I originally installed it for the “Ring my phone from my computer” feature, but I’m using all kinds of stuff nowadays.

:+1:

3 Likes

Hi Fabby!

  1. Ensured

  2. Output:

ps -ef | grep kdeconnect                  
marko       1035       1  0 sept 15 ?      00:00:01 /usr/lib/kdeconnectd
marko       8311    2537  0 00:13 pts/1    00:00:00 grep kdeconnect

Seems to be fine though not matching yours.

  1. Sudo tells me netstat: command not found

  2. Turned off. KDE Connect came back on. Was able to pair. Turned the firewall on. Vanished.

How do I add an exception to the firewall for KDE Connect or what do I do? :smiley:

I use plasma-firewall as the GUI for firewall.

Best Regards,

Marko

First, learn what you will need to enter: open the firewall GUI of plasma-firewall.

BTW, it contains the lack, which you can report to upstream (KDE) developers


But there is no add rule btn.
Maximise window and restore it size.
buttons now appears:

If you want to support the app you use, please report that lack.

Press add rule btn. Learn what parameters needs to be entered to create a new rule.

$ pacman -Qi plasma-firewall
Name            : plasma-firewall
Version         : 5.22.5-1
Description     : Control Panel for your system firewall
...

kinfocenter about-distro shows:

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.4-1-MANJARO (64-bit)
Graphics Platform: X11

Then, learn the KDE Connect app usage:
-) theoretically by it’s docs
or
-) load LiveCD session, and view output of

sudo lsof -ni

KDE Connect should be turned on and be listed there: just grab all you need: path, protocol, port, user, etc. from that output.
Load OS installation copy and add your new rule(s) according to specs you have just learned.

  1. :clap:

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

:innocent:
P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
Solution
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I don’t even know which one you have: you installed it, you should read the manual! :grin:

If you’re stiil interested in:

  1. pamac install net-tools
1 Like

I think by default it comes with ss instead of netstat:
sudo ss -atunp

1 Like

Fabby, do you mean the post by alven?

EDIT
Oh. Now I get what’s going on…

Erm, no… mine???

image

:confused:

Disabling the firewall solved it, right? How to open the right ports would be another (new) topic depending on your FW…

2 Likes

Yes I just realized :smiley: :smiley:

Sorry Fabby!!

1 Like

Go away and don’t come back here until you’ve had at least:

:coffee: :coffee: :coffee:

:joy:

Actually, looking at your time zone:

:bed: :first_quarter_moon_with_face: :zzz:
:wave:

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.