KDE: Brother printers constantly stop working

I have 3 machines running Manjaro KDE that have different Brother laser printers installed (via WiFi). I disabled printer discovery in local network, so all printers were manually installed via CUPS using ipp:// protocol (as per Arch wiki).

Printers work great, except… every month or so they randomly stop working. Printers are still displayed in CUPS, but printing doesn’t work - CUPS always displays error “unable to process job” (or similar, can’t remember the exact text right now). Sometimes reboot does help, but most often it doesn’t. The only way to get printers working again is to manually delete and re-add them via CUPS. Once I re-add printers, they start working instantly. For a month or so…

I know CUPS daemon was modified during last Manjaro update, but I re-enabled new CUPS daemon as per upgrade instructions, and printers worked fine… But stopped working yesterday (no updates received yesterday). Hence, I have absolutely no idea what causes these outages, especially because they occur for last 6 months or so…

P.S. I also have 5 more machines running Kubuntu (attached to the same printers) and they work perfectly for years… So it’s definitely not related to printer and/or router.

Hi @toxpal,
Could you read this post in order to see whether it solves the problem ?

Hope it help, regards.

So either your configs are changing, or, more likely, your IPs are changing on your router.

Try setting your browser not through IP but by printer’s name, or change your router settings to keep the IPs.

I can’t provide you with a more detailed answer, you have to discover the details on your own.

There is a server running on a router that rotates IPs of connected devices. That’s usually a default setting, and I feel is the cause of your problem.

Alternatively, if you cannot change that, try using different connection protocols. For example, on one of my printer’s I have a connection via the device name:


No idea where I got the name thou…

On another printer, it is found by the device uuid:


Some connection protocols may need to install additional packages for them to work.

P.S. I assume you already installed the proper drivers from AUR.

Could you confirm if the link is correct? I get " Oops! That page doesn’t exist or is private" error.

Thank you for your reply. I can confirm IPs are not changed and always remain the same. When I re-add printer, I use exactly the same information (including IP). And then it works again.

Tried that. Only works with IPP in my case, as per Arch wiki - CUPS/Printer-specific problems - ArchWiki

Yes, absolutely.

Hm… The best bet would be to wait for the error again and debug it. Without the cause, we don’t know how to fix it.

I guess you have to educate yourself how to debug cups or in general printing issues, which logs to read, where to check, etc.

Maybe your router has some weird security setting and blocks the connection when some specific situation appears? It’s possible that the new connection has some fresh id and that resets it. Or maybe I’m just looking in a wrong place.

Anyway, with wifi, you always need to take into account also firewall, router settings aside CUPS themselves.

Also, why other protocols are not working? This could also point out on specifics of your wireless setup and suggest what may be the issue.

I use brother devices and have no issues with them. Drivers are primitive but workable and are very similar across various models (at least function wise), so there has to be something unique with your setup that is causing these issues.

Since there are many points where the problem may occur, it’s not easy to debug.

Anyway, here are some resources about debuging printer issues:




I don’t think it’s the case because Kubuntu works without any problems. I didn’t mention before, but when issue happens with Manjaro, it doesn’t mean all Manjaro machines stop printing the same day. The issue occurs randomly on each Manjaro machine. So definitely not router fault, IMHO.

I checked all these wiki articles before, but without luck. I guess I’ll just wait for issue to occur again to debug it further. Just thought someone else had the same problem and know a solution already…

1 Like

Another Manjaro KDE update and… printer stopped working again. I was able to fix it by using troubleshooting tips from Arch, and fix was to delete old CUPS config file and create new one using default settings.

While this solution works, it’s really annoying, especially when no such hacking is needed on Ubuntu-based distros. But I guess the issue is related to Arch itself, and not Manjaro?