KDE brightness control not working

Hello everyone, nice to meet you all. Thisi s my first post in the community. I recently upgraded my Manjaro system to its’ lastest version. I am using kernel 5.14 and my laptop is an Acer 5742-6991. Since yesterday I haven’t been able to adjust the screen brightness. I tried to search on google but I didn’t find anything useful to solve the issue. Excuse if this has been anwsered before, as I said this is my first post, so, if it needs to be moved to another section, I would like to know. Thank you very much for any help that any of you may provide.

Welcome to the forum :innocent:

Consider using a LTS kernel (such as 5.10)

Go to system settings and then to Kernels

Install the Kernel 5.10
Then reboot.
While booting select Advanced Options from grub and there select to boot from 5.10
[If you have only Manjaro installed, you have to press Escape while booting to access grub]

Thank you very much Shirshendu. I will try it out to see if it works. :slight_smile:

Hello Shirshendu, how are you? I just rebooted my computer and selected Kernel 5.10 to start the system as you suggested, but, It didn’t work, the brightness function isn’t working. What else could I do?

Fine, here.

It worked for me once, that’s why I suggested it. :sweat_smile:

Is the brightness adjustment settings not working or is it missing?
By the way, is acpi installed? If not install it, sudo pacman -S acpi

Hello, how are you? Well, if by settings you mean the bar on the battery where I can adjust the brightness or the battery section in “system settings”, those are there. I just try to adjust it through the bar or in system settings and it doesn’t work (by the way my native language is Spanish, so perhaps “settings” are elsewhere (my system is in English but just in case). Acpi is installed in my system.