Kde black screen after boot

hi, i have this issue since the installation.when i turn on the system, sometimes after showing the asus logo , the system does not load the desktop and shows a black screen without mouse cursor or type pointer. then when i restart the system by physical key, it loads just fine. i tried the Ctrl+Alt+F2 and F1 and etc… in black screen with no luck. also i pressed ‘e’ in grub and added ‘nomodeset quiet splash’ , when it boots stuck on ’ [“… clean, … files, … blocks”]’ and nothing happen (also tested ''nomodeset i915.modeset=0 nouveau.modeset=0 same result).

  • using nvidia GM108M [GeForce 930MX] with intel integrated

Hello @sina_rajabpour :wink:

To point you in the direction: It could be possible that the system starts too fast, so that the GPU is not ready and the display-manager does not wait for the gpu to become ready… It is an issue with gdm and lighdm sometimes.



Possible that the issue effects now sddm also by a cold start. You could try to add some extra time at the sddm service like the gdm service explained at the link above.

1 Like

Hello @megavolt Thanks alot ! i found this section in your links :

wiki .archlinux .org/title/Kernel_mode_setting#Early_KMS_start

And changed the modules in this file /etc/mkinitcpio.conf (according to above link) :

MODULES=(intel_agp i915 nouveau nvidia nvidia_modeset nvidia_uvm nvidia_drm)

Problem Solved permanently :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.