KDE Autostart script not starting

I’m trying to make a script that uses rclone to mount my cloud storage, and for some reason, the file only works when I run it manually. The file contents are:

rclone mount --daemon gdrive: /home/user/gdrive
rclone mount --daemon oneDrive: /home/user/OneDrive

Of course, I have used ‘chmod +x [filename]’, as I am able to execute the file manually. It’s worth noting that I had a script very similar to this which worked, that I ended up changing, as I edited “oneDrive” from “drive”, and now the autostart script does not work. I’ve tried to simply make a new .sh file, with a different name, to no avail.

Figured it out, I placed the scripts in a folder with a space in it:
/home/user/Documents/Startup\ Scripts/cloud.sh
And in the autostart preferences, the command didn’t account for the space in the file name. It was:
/home/user/Documents/Startup Scripts/cloud.sh
which, of course, would always fail.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.