Kde apps open minimized in panel rather than maximized on the desktop

I had some problems with my panel so I went back to the default settings. Now whenever I open an app by clicking on its icon in the panel it opens minimized in the task manager. Previously it would open maximized on the desktop and I cannot find the setting to restore this behaviour.

Look here: System Settings > Window Behavior > Advanced and confirm that “Allow apps to remember the positions…” is checked.

Then… right-click in upper left-hand window decoration for drop-down menu of the app that is misbehaving on you. Select More Actions and then Configure Special Application Settings

You can then +Add Property and select the Size & Position you’d like to see when you open that app.

Others with more experience around here could likely give you guidance to get this accomplished with much less fuss. In which case, I’d like to know, too!

Thanks SomeGuy but I hope to find a simpler solution. If not, I will give yours a go.