Kann mein Manjaro nicht aktualisieren. Pipewire Pulseaudio Problem

Wenn ich mit der Systemaktualisierung starte bekomme ich jetzt zwei Möglichkeiten, die ich auswählen darf. Beide führen zur selben Fehlermeldung und die Aktualisierung wird nicht gestartet. Hier sind meine Screenshots.

Danke für eure Hilfe:-)

asoa1

sudo pacman -R pulseaudio-equalizer
run update again
and choose the wireplumber

Habe ich im Terminal eingegeben und die Frage mit ja beantwortet

In der Aktualisierungsverwaltung wireplumber angegeben. Fehlermeldung mit pulseaudio ist immer noch da.

aber sicher nicht die selbe wenn du das equalizer paket entfernt hast so wie @brahma das empfohlen hat

ok, ich schaue nochmal :wink:

https://archlinux.org/news/undone-replacement-of-pipewire-media-session-with-wireplumber/

Fehlermeldung:

Kann Abhängigkeiten nicht erfüllen:

  • das Entfernen von pulseaudio verletzt Abhängigkeit ‘pulseaudio=16.1-1’ benötigt von pulseaudio-jack

Das heißt, das darf ich nochmal in den Terminal eingeben,wie in deinem Link angegeben?

pacman -Syu pipewire-media-session

ja installiere das paket, neustarten und dann das update nochmal starten.

Fehlermeldung ist immer noch da.

also ich habe den pipwire Befehl im Terminal eingegeben. Alle fragen mit ja beantwortet(siehe Screenshot) und Rechner runtergefahren.

Kann Abhängigkeiten nicht erfüllen:

  • das Entfernen von pulseaudio verletzt Abhängigkeit ‘pulseaudio=16.1-1’ benötigt von pulseaudio-jack

entferne alle:

sudo pacman -R pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

Bitte keine Screenshots von Text. Bei GUIs geht das wohl nicht ohne, aber bei dem Terminal kann man das auch ganz bequem kopieren und einfügen. Die Vorteile von Text gegenüber Bildern muss denke ich mal nicht weiter erwähnt werden.


Wenn man eine Terminalausgabe einfügt, dann bitte mit drei rückwärts geneigten Hochkommas ` ODER 3 Wiederholungszeichen ~ über und unter dem Text:

Text

Dankeschön :bowing_man:

sudo pacman -R manjaro-pulse pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

Das mit dem Screenshots habe ich sogar jetzt gerade selbst erkannt.

ok, habe ich eingegeben, dann folgende Meldung:

[max@max-pc ~]$ sudo pacman -R pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf
[sudo] Passwort für max:
Abhängigkeiten werden geprüft …
Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Entfernen von pulseaudio-zeroconf verletzt Abhängigkeit »pulseaudio-zeroconf«, benötigt von manjaro-pulse

pamac remove manjaro-pulse

[max@max-pc ~]$ pamac remove manjaro-pulse
Vorbereitung...
Abhängigkeiten werden überprüft...

Wird entfernt (1):
  manjaro-pulse  20220217-2    extra


Transaktion anwenden ? [j/N] j
Entferne manjaro-pulse (20220217-2)...                                     [1/1]
Vorgang erfolgreich abgeschlossen.

Aktulalisierungsverwaltung nach wireplumber auswahl: Meldung

Kann Abhängigkeiten nicht erfüllen:
- das Entfernen von pulseaudio verletzt Abhängigkeit 'pulseaudio=16.1-1' benötigt von pulseaudio-jack

Vielleicht Rechner neustarten?

Lieber @knatschfisch :wink:

manjaro-pulse is nur eine Gruppe von Paketen. Du musst alle Pakete entfernen, die stören “davon abhängen” und dann die Gruppe manjaro-pipewire installieren. Das ist der Weg, den hier alle versuchen.

Leider funktioniert der Wechsel hier bei dir nicht reibungslos aus unbekannten Gründen.

Alles klar. Vielleicht hat ja noch irgendjemand eine Idee. Ich warte dann noch. Ansonsten werde ich irgendwann die neueste Manjaro Version runterladen und nochmal alles neu installieren. Ich hatte sowieso immer wieder alle 2-3 Monate pulse audio Probleme,wenn ich aktualisieren wollte. Konnte bisher immer gelöst werden. Kann es eigentlich sein, dass Pulse Audio allgemein veraltet ist und das sowie versucht wird jetzt runter zu nehmen?

Bis hierhin schon Mal ein großes Dankeschön. Besser als jeder andere Support.

i gave you command above to remove them all:

sudo pacman -R manjaro-pulse pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf