Jupyter notebook can not find MathJax

Hi,

Jupyter notebook can not find MathJax.

Regards,
Todor

After installation the Jupyter Notebook with the Manjaro Package Manager and when the jupyter notebook is started on working ipynb file this is the first message box which is displayed

You probably need to install jupyter-server-mathjax.

Thanks for your reply.

It is installed.

I have used before the last update the Jupiter Notebook without problems. This happened after this last update and in the same way on two different computers.

You have to provide a more detailed log.

Sorry for my omission,
here you have the jupyter-notebook log


I tried to install any extension jupyterlab but unsuccessfully

and here again the brower view of:

From Math and equations

By default MathJax version 2 is currently used.

@todork I am not sure this will work but can you try removing mathjax package and install mathjax2.

@ishaanbhimwal Thanks for the reply.
The package mathjax is not installed and I preinstalled again mathjax2 with Manjaro Package Manager without any success.

Hi guys,
I have to do some job with the comp so I switched back to the stable branch and everything is working fine. So, obviously this is testing branch problem. I will appreciate if you keep me informed if this problem is solved and how.

Thanks and Regards

I’m sorry for having been so blunt. Usually, I only use virtualenvs (or docker) but I’ve tested the repo version from unstable and I can see the same error message.

@mithrial No Problem. The important thing is to reproduce the issue.
Thanks

@todork Can you try jupyter-notebook version 6.4.10-2. It is in Unstable branch right now. Mathjax issue was fixed yesterday.

Edit - In case you don’t want to switch branch then remove the regular jupyter-notebook package and run this command to directly install it from unstable.

sudo pacman -U https://mirror.alpix.eu/manjaro/unstable/community/x86_64/jupyter-notebook-6.4.10-2-any.pkg.tar.zst
2 Likes

@ishaanbhimwal Thank you for you prompt reaction, everything seems to be OK.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.