Journalctl pulseaudio error after latest update

hello!

After the last update I got the following error in journal

pulseaudio[1005]: GetManagedObjects() failed: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy bleive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

I use:
OS: Manjaro 20.2 Nibia
Kernel: x86_64 Linux 5.4.77-1-MANJARO
Shell: bash
DE: Xfce4
WM: Xfwm4
WM Theme: Matcha-sea
GTK Theme: Matcha-sea [GTK2]

I will be grateful for advice on how to fix this.

metoo - have not found any solution -seems to be harmless - as sound is working…

I understand that the error is related to bluetooth (possibly).

But I have a stationary personal computer, and there is no bluetooth module on it.

I executed the command

sudo systemctl disable bluetooth

The error disappeared, but a new error appeared:

pulseaudio[1004]: GetManagedObjects() failed: org.freedesktop.systemd1.NoSuchUnit: Unit dbus-org.bluez.service not found.

It doesn’t seem like a solution

Has anyone gotten a solution? I’m also getting that error and its really bugging me.

same issue…any solution?

Check if PulseAudio has any active modules related to Bluetooth

pacmd dump | grep module-bluetooth

PulseAudio usually has 2 modules loaded by default
module-bluetooth-policy and module-bluetooth-discover

to disable the modules, use this command to add comment tags to the configuration file

sudo sed -Ei '/load-module module-bluetooth*/s/^/#/' /etc/pulse/default.pa

then reboot or restart system, or use this command to restart PulseAudio

systemctl --user restart pulseaudio
5 Likes

sudo sed -Ei '/load-module module-bluetooth*/s/^/#/' /etc/pulse/default.pa
This helped on my Installation- after I did:
sudo systemctl enable bluetooth
and restarting machine…

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.