Jittery animations when connected to external high refresh rate monitor (Wayland)

  Kernel: 5.10.93-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Latitude E7440 v: 00
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Dell model: 06MFX3 v: A01 serial: <superuser required> UEFI: Dell
    v: A28 date: 06/13/2019
  ID-1: BAT0 charge: 33.0 Wh (85.1%) condition: 38.8/47.7 Wh (81.5%)
    volts: 8.4 min: 7.4 model: SMP DELL 909H538 type: Li-ion serial: <filter>
    status: N/A
  RAM: total: 7.68 GiB used: 3.52 GiB (45.8%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: dual core model: Intel Core i5-4310U bits: 64 type: MT MCP
    smt: enabled arch: Haswell rev: 1 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1830 high: 2594 min/max: 800/3000 cores: 1: 956 2: 1371
    3: 2400 4: 2594 bogomips: 20760
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Dell driver: i915
    v: kernel bus-ID: 00:02.0 chip-ID: 8086:0a16 class-ID: 0300
  Device-2: Microdia Integrated Webcam type: USB driver: uvcvideo
    bus-ID: 2-4:3 chip-ID: 0c45:64d2 class-ID: 0e02
  Display: x11 server: X.org compositor: kwin_x11 driver:
    loaded: modesetting alternate: fbdev,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Haswell-ULT HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:03.0 chip-ID: 8086:0a0c class-ID: 0403
  Device-2: Intel 8 Series HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.93-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.43 running: yes
  Device-1: Intel Ethernet I218-LM vendor: Dell driver: e1000e v: kernel
    port: f080 bus-ID: 00:19.0 chip-ID: 8086:155a class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel bus-ID: 02:00.0
    chip-ID: 8086:08b1 class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
    bus-ID: 1-1.3:3 chip-ID: 8087:07dc class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 7 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: f060 bus-ID: 00:1f.2 chip-ID: 8086:282a rev: N/A
    class-ID: 0104
  Local Storage: total: 1.14 TiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Crucial model: CT240BX500SSD1 size: 223.57 GiB
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: R013 scheme: GPT
  ID-2: /dev/sdb type: USB model: External USB3.0 size: 931.51 GiB
    type: N/A serial: <filter> rev: 0204 scheme: GPT
  ID-3: /dev/sdc type: USB vendor: SanDisk model: Cruzer Force
    size: 14.56 GiB type: N/A serial: <filter> rev: 1.27 scheme: MBR
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/dm-0 mapped: ventoy size: 2.99 GiB fs: iso9660
  ID-2: /dev/sda1 size: 300 MiB fs: vfat label: NO_LABEL uuid: 8194-3FAC
  ID-3: /dev/sda2 size: 16 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-4: /dev/sda3 size: 96.31 GiB fs: ntfs label: N/A
    uuid: 7E5EB08C5EB03F29
  ID-5: /dev/sda4 size: 126.95 GiB fs: ext4 label: N/A
    uuid: 5bd7050e-f736-4eee-8c37-a1bdfb9a6f81
  ID-6: /dev/sdb1 size: 839.84 GiB fs: ntfs label: Data
    uuid: A666699466696651
  ID-7: /dev/sdb2 size: 91.67 GiB fs: ext4 label: timeshift
    uuid: ef797067-6d9b-42b0-8957-049f399b1e02
  ID-8: /dev/sdc1 size: 14.53 GiB fs: vfat label: ventoy uuid: C340-1231
  ID-9: /dev/sdc2 size: 32 MiB fs: vfat label: VTOYEFI uuid: 7506-0A74
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:8000 class-ID: 0900
  Device-1: 1-1.3:3 info: Intel Bluetooth wireless interface
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:07dc class-ID: e001
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-2:2 info: SanDisk Cruzer Force type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 200mA
    chip-ID: 0781:557d class-ID: 0806 serial: <filter>
  Device-2: 2-4:3 info: Microdia Integrated Webcam type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:64d2 class-ID: 0e02
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 3-3:2 info: JMicron / JMicron USA JMS578 SATA 6Gb/s
    type: Mass Storage driver: uas interfaces: 1 rev: 3.0 speed: 5 Gb/s
    power: 896mA chip-ID: 152d:0578 class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 56.0 C mobo: 39.0 C sodimm: SODIMM C
  Fan Speeds (RPM): cpu: 3713
  Processes: 200 Uptime: 2h 51m wakeups: 3 Init: systemd v: 250 Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1103 Shell: Zsh v: 5.8
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.12

I am using kde plasma wayland, When I connect my high refresh rate external display all the animations appear jittery, everything which moves appears to be vibrating. The display is detected as 120hz. All this issue disappears when i set the external display as 60 hz from 120hz, and then again to 120hz. I tried endeavouros also and no issue there.

EndeavourOS has kernel 5.16 right now. I see you’re running 5.10 on Manjaro. That may be the difference.

I have tried changing kernel too. Can i try eos kernel on manjaro?

ofcourse not!

but in gnome everything is fine with same kernel.

Endeavor is pretty much stock arch your on stable manjaro which is probably 2 or 3 weeks behind EOS. There’s a chance that a fix may get pushed. You could try switching branches and see if that helps. At the moment we’re just guessing

I already waited for manjaro plasma 5.23.5 because when i tried eos it was on that and manjaro was on 5.23.4, and i thought maybe thats why, but the issue still persists. Thanks for you time.

If you suspect the issue is version related - bear in mind that everything on Manjaro is different. That goes for packages, kernels, modules and drivers which is different from stable to unstable to Arch and that EndeavourOS uses plain Arch untouched repos.

Thus you cannot compare EndeavourOS and Manjaro - they are fundamentally different.

You could try switching your Manjaro to use unstable and run a full system sync.

sudo pacman-mirrors -aS unstable && sudo pacman -Syyu

Then recheck if the issue is fixed.

1 Like

I don’t think its version related, i guess its because of drivers. Its like my system detects that i have plugged in 120hz display and shows 120hz in display settings, but doesn’t switch to it. When i manually change the RR to 60hz and then again to 120 everything works as expected. Moreover, when i drop the RR from 120hz to 60 for the first time just after plugging in the monitor, all the jitter and animations smoothness remains the same which indicates that the monitor was already running at 60 but was showing as 120.

Hmm - I have a 240Hz monnitor - it is only seen as 120Mz - not a big deal to me - more like a luxury issue - I am just a codemonkey :slight_smile:

You can’t, but you can update to Manjaro’s kernel 5.16. 5.10 is a LTS release.
If you wish to update your kernel to stable 5.16:
sudo pacman -Sy linux516 linux516-headers
Use: sudo mhwd-kernel -i linux516

Please don’t give lousy and dangerous (-Sy very good for a partial upgrade) commands, Manjaro’s way of installing new kernels is described here - Manjaro kernels, if then the user wants to know more about the background/architecture of Linux, he/she can either explicitly ask for that in the forums or study it by him/herself. Copy pasting commands blindly is the fastest way to a broken system while not having the slightest idea what to do next and making everyone’s life more difficult.

1 Like

Sorry, just fixed my mistake
I used pacman last time i upgraded my kernel, i’m lucky i did not broke my system