Jetbrains toolbox installation (noob alert)

I tried to install the jetbrains Toolbox from aur packages but every time i open it it ask to integrate into the system, and fail if i integrate.
The first time it fail it ask to copy only the appimage, but the next time i open it will reask to integrate, and if i integrate if fail because the appimage already exist in the folder.
If i don’t integrate it and click run it work good.

i tried to unistall and reinstall, with no luck.

I searched a lot, it seems that the appimage of jetbrains Toolbox is different from the others, but didn’t find anything with a solution.

How can i integrate it to the system manually or just remove the popup that ask to integrate?
I’m new to manjaro but not new to linux, if any additional information is needed i will provide it.


I use it - it works fine - but I don’t use KDE either - don’t install from AUR. It should be fine extracting the archive and running the enclosed binary which will propagate to ~/.local and run from there. Applications installed using the toolbox the described way will install to ~/.local and never give you any trouble system wise.

Don’t ever run using sudo when installed like described above.

i unistalled the toolbox from aur and installed from their archive, but appimage ask anyway to integrate it into the system. (the forum does’t let me upload an image or put a link)

how can i remove this popup?

i tried to do a soft link with the binary of the toolbox, so that appimage could see an app in ~/Apllications, with no luck.

I think you are complicating things somewhere.

When required I just download the toolbarc archive unpack and run the app image - then you can remove the files an use the launcher created.

The integration is a line in .~/config/mimeapps.list and is only when you authenticate your license or subscription - if you have such thing. I do because it is the best tools on the planet.

Even you don’t have a subscription the community versions of IDEA and PyCharm are pretty awesome.