JETBRAINS IDEA randomly Freeze

Hello to all,

Since a few days I observe a problem when using IDE JETBRAINS (I observed the problem on IDEA, WEBSTORMS, PYCHARM).

The software freezes completely for several seconds, until sometimes I have to force the restart of my PC.

I have contacted Jetbrains support and provided the LOG files. The log shows the IDEA frozen in some X11 cursors related native code for some reason.

I have the same problem in kernel 6.0 and 6.1. I can’t use 5.X kernels for sound problems.

Have any of you encountered the problem and solved it? I’m still in contact with the software support but I’m not sure if I’ll get an answer soon.

Thanks in advance to all of you!

They are proprietary software. You should contact their customer support.

From experience, they consume a lot of memory. Close all other running applications and increase Swap.

Thank you for your feedback, i’m waiting answers from jetbrains. My PC has 32GB of RAM, and apart from my browser no software is open at this time. Moreover, the problem occurs even if the open project has only one file with 2 or 3 lines of code…

On the other hand, I didn’t set up a swap, thinking that the 32 GB would be enough. Should I do it?

Hello,

I don’t think it’s a swap problem, the memory is limited or partitioned by the jvm.
I am using the ultimate version and I don’t have any problem at the moment, but it happens sometimes when updating java or plugins.
You need to look at the logs, you should find them in the help menu. I also had problems with plugins, the logs are the starting point.

Good luck

I @kurdy , thank you for the feed back. What I have in the log file is :

2023-01-14 23:08:43,196 [ 264019]   WARN - #c.i.d.PerformanceWatcherImpl - UI was frozen for 12666ms, details saved to /home/l*****/.cache/JetBrains/IntelliJIdea2022.3/log/threadDumps-freeze-20230114-230835-IU-223.8214.52-12sec

When i open the specific log file for this warning :

"AWT-EventQueue-0" prio=0 tid=0x0 nid=0x0 runnable
     java.lang.Thread.State: RUNNABLE
 (in native)
	at java.desktop/sun.awt.X11.XlibWrapper.XQueryPointer(Native Method)
	at java.desktop/sun.awt.X11.XMouseInfoPeer.fillPointWithCoords(XMouseInfoPeer.java:56)
	at java.desktop/java.awt.MouseInfo.getPointerInfo(MouseInfo.java:89)
	at com.intellij.openapi.ui.UiUtils.isComponentUnderMouse(UiUtils.kt:58)
	at com.intellij.openapi.editor.toolbar.floating.TransparentComponentAnimator.isComponentUnderMouse(TransparentComponentAnimator.kt:115)
	at com.intellij.openapi.editor.toolbar.floating.TransparentComponentAnimator.nextState(TransparentComponentAnimator.kt:99)
	at com.intellij.openapi.editor.toolbar.floating.TransparentComponentAnimator$$Lambda$2511/0x0000000101810548.apply(Unknown Source)
	at java.base@17.0.5/java.util.concurrent.atomic.AtomicReference.updateAndGet(AtomicReference.java:210)

These are only the first lines, I don’t know how to interpret this file afterwards… I don’t really know what to do after.

Thank you in advance.

It seems that the problem is with openapi plugin editor. If you have that plugin you may try to disable it and see if it continue to freeze.

Note I personally use online tools for openapi due to Swagger’s decreasing motivation to maintain its open tools.

Hi Kurdy,

I got a answer from jetbrains that solved this issue. I add this :

-Dsun.java2d.opengl=true

in :

Help | Edit Custom VM Options

I don’t know what it means but it works !

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.