Jellyfin doesn't work after update

I have been using a jellyfin server for the past few months now and after a recent manjaro update the server isn’t working
I tried,
sudo systemctl status jellyfin

     jellyfin.service - Jellyfin Media Se>
     Loaded: loaded (/usr/lib/systemd/>
     Active: failed (Result: exit-code>
    Process: 3644 ExecStart=/usr/bin/d>
   Main PID: 3644 (code=exited, status>
        CPU: 10ms

Dec 26 23:04:36 vostro14 systemd[1]: S>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 dotnet[3644]:>
Dec 26 23:04:37 vostro14 systemd[1]: j>
Dec 26 23:04:37 vostro14 systemd[1]: j>
lines 1-17/17 (END)...skipping...
× jellyfin.service - Jellyfin Media Server
     Loaded: loaded (/usr/lib/systemd/system/jellyfin.service; enabled; vendor >
     Active: failed (Result: exit-code) since Sun 2021-12-26 23:04:37 IST; 37s >
    Process: 3644 ExecStart=/usr/bin/dotnet /usr/lib/jellyfin/jellyfin.dll --da>
   Main PID: 3644 (code=exited, status=150)
        CPU: 10ms

Dec 26 23:04:36 vostro14 systemd[1]: Started Jellyfin Media Server.
Dec 26 23:04:37 vostro14 dotnet[3644]: It was not possible to find any compatib>
Dec 26 23:04:37 vostro14 dotnet[3644]: The framework 'Microsoft.AspNetCore.App'>
Dec 26 23:04:37 vostro14 dotnet[3644]:   - The following frameworks were found:
Dec 26 23:04:37 vostro14 dotnet[3644]:       6.0.0 at [/usr/share/dotnet/shared>
Dec 26 23:04:37 vostro14 dotnet[3644]: You can resolve the problem by installin>
Dec 26 23:04:37 vostro14 dotnet[3644]: The specified framework can be found at:
Dec 26 23:04:37 vostro14 dotnet[3644]:   ->
Dec 26 23:04:37 vostro14 systemd[1]: jellyfin.service: Main process exited, cod>
Dec 26 23:04:37 vostro14 systemd[1]: jellyfin.service: Failed with result 'exit>

Do i need to downgrade the mentioned framework?, if yes, then how?
Here’s My system info if required.
Any help is appreciated.

Kernel: 5.10.84-1-MANJARO x86_64 bits
: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinu
66bd1117794 rw quiet apparmor=1
security=apparmor udev.log_priority
Desktop: KDE Plasma 5.23.4 tk: Qt 5.1
5.2 info: latte-dock wm: kwin_x11
vt: 1 dm: SDDM Distro: Manjaro Linu
x base: Arch Linux
Type: Laptop System: Dell product: Vo
stro 14-3468 v: N/A
serial: <superuser required> Chassi
s: type: 9 serial: <superuser required>
Mobo: Dell model: 01CM9N v: A01 seria
l: <superuser required> UEFI: Dell
v: 2.5.0 date: 04/19/2018
RAM: total: 3.71 GiB used: 2.32 GiB (
RAM Report:
permissions: Unable to run dmidecod
e. Root privileges required.
Info: model: Intel Core i3-7100U bits
: 64 type: MT MCP arch: Amber/Kaby Lake
note: check family: 6 model-id: 0x8
E (142) stepping: 9 microcode: 0xEA
Topology: cpus: 1x cores: 2 tpc: 2 th
reads: 4 smt: enabled cache:            
L1: 128 KiB desc: d-2x32 KiB; i-2x3
2 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 1100 min/max: 400/2
400 scaling: driver: intel_pstate
governor: powersave cores: 1: 1100
2: 1100 3: 1100 4: 1100 bogomips: 19204
Flags: 3dnowprefetch abm acpi adx aes
aperfmperf apic arat arch_perfmon
art avx avx2 bmi1 bmi2 bts clflush
clflushopt cmov constant_tsc cpuid
cpuid_fault cx16 cx8 de ds_cpl dtes
64 dtherm dts epb ept ept_ad erms est
f16c flexpriority flush_l1d fma fpu
fsgsbase fxsr ht hwp hwp_act_window
hwp_epp hwp_notify ibpb ibrs intel_
pt invpcid invpcid_single lahf_lm lm
mca mce md_clear mmx monitor movbe
mpx msr mtrr nonstop_tsc nopl nx pae
pat pbe pcid pclmulqdq pdcm pdpe1gb
pebs pge pln pni popcnt pse pse36 pti
pts rdrand rdseed rdtscp rep_good s
dbg sep smap smep ss ssbd sse sse2
sse4_1 sse4_2 ssse3 stibp syscall t
m tm2 tpr_shadow tsc tsc_adjust
tsc_deadline_timer vme vmx vnmi vpi
d x2apic xgetbv1 xsave xsavec xsaveopt
xsaves xtopology xtpr
Type: itlb_multihit status: KVM: VMX
Type: l1tf
mitigation: PTE Inversion; VMX: con
ditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffe
rs; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypas
s disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barrier
s and __user pointer sanitization
Type: spectre_v2 mitigation: Full gen
eric retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB fi
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not aff
Device-1: Intel HD Graphics 620 vendo
r: Dell driver: i915 v: kernel          
bus-ID: 00:02.0 chip-ID: 8086:5916
class-ID: 0300                          
Device-2: Microdia Integrated_Webcam_
HD type: USB driver: uvcvideo
bus-ID: 1-5:5 chip-ID: 0c45:6a05 cl
ass-ID: 0e02                            
Display: x11 server: X.Org c
ompositor: kwin_x11 driver:             
loaded: modesetting alternate: fbde
v,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96
s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP-1 res: 1366x768 hz: 60
dpi: 112 size: 309x173mm (12.2x6.8")
diag: 354mm (13.9")
OpenGL: renderer: Mesa Intel HD Graph
ics 620 (KBL GT2) v: 4.6 Mesa 21.2.5
direct render: Yes
Device-1: Intel Sunrise Point-LP HD A
udio vendor: Dell driver: snd_hda_intel
v: kernel alternate: snd_soc_skl bu
s-ID: 00:1f.3 chip-ID: 8086:9d71        
class-ID: 0403
Sound Server-1: ALSA v: k5.10.84-1-MA
NJARO running: yes
Sound Server-2: JACK v: 1.9.19 runnin
g: no                                   
Sound Server-3: PulseAudio v: 15.0 ru
nning: yes                              
Sound Server-4: PipeWire v: 0.3.40 ru
nning: yes                              
Device-1: Intel Wireless 3165 driver:
iwlwifi v: kernel bus-ID: 01:00.0
chip-ID: 8086:3165 class-ID: 0280
IF: wlp1s0 state: up mac: <filter>
IP v4: <filter> type: dynamic noprefi
xroute scope: global
broadcast: <filter>
IP v6: <filter> type: dynamic noprefi
xroute scope: global
IP v6: <filter> type: noprefixroute s
cope: link                              
Device-2: Realtek RTL8111/8168/8411 P
CI Express Gigabit Ethernet
vendor: Dell driver: r8169 v: kerne
l port: e000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: down mac: <filter>
WAN IP: <filter>
Device-1: Intel Bluetooth wireless in
terface type: USB driver: btusb v: 0.8
bus-ID: 1-8:7 chip-ID: 8087:0a2a cl
ass-ID: e001                            
Report: rfkill ID: hci0 rfk-id: 1 sta
te: up address: see --recommends        
Message: No logical block device data
Message: No RAID data found.
Local Storage: total: 1.36 TiB used:
143.69 GiB (10.3%)
SMART Message: Unable to run smartctl
. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: S
eagate model: ST1000LM035-1RK172
size: 931.51 GiB block-size: physic
al: 4096 B logical: 512 B speed: 6.0 Gb
type: HDD rpm: 5400 serial: <filter
> rev: SDM2 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: US
B vendor: Toshiba model: MQ01ABF050
size: 465.76 GiB block-size: physic
al: 512 B logical: 512 B type: HDD      
rpm: 5400 serial: <filter> rev: AM0
0 scheme: MBR
Message: No optical or floppy data fo
ID-1: / raw-size: 931.22 GiB size: 91
5.53 GiB (98.32%)
used: 93.43 GiB (10.2%) fs: ext4 de
v: /dev/sda2 maj-min: 8:2 label: N/A    
uuid: 9ed067f5-9fca-4ad0-80bc-f66bd
ID-2: /boot/efi raw-size: 300 MiB siz
e: 299.4 MiB (99.80%)                   
used: 308 KiB (0.1%) fs: vfat dev:
/dev/sda1 maj-min: 8:1 label: NO_LABEL
uuid: 3E5B-9919
ID-3: /run/media/advait/0d0ffc56-c6bd
raw-size: 465.76 GiB size: 457.45 G
iB (98.22%) used: 50.27 GiB (11.0%)
fs: ext4 dev: /dev/sdb1 maj-min: 8:
17 label: N/A
uuid: 0d0ffc56-c6bd-4708-8157-5906f
Alert: No swap data was found.
Message: No unmounted partitions foun
Hub-1: 1-0:1 info: Hi-speed hub with
single TT ports: 12 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002
class-ID: 0900                          
Device-1: 1-1:2 info: CASUE USB KB ty
pe: Keyboard,HID                        
driver: hid-generic,usbhid interfac
es: 2 rev: 1.1 speed: 1.5 Mb/s          
power: 100mA chip-ID: 2a7a:938f cla
ss-ID: 0300                             
Device-2: 1-2:3 info: Xenta 2.4G Wire
less Optical Mouse type: Mouse
driver: hid-generic,usbhid interfac
es: 1 rev: 2.0 speed: 1.5 Mb/s          
power: 100mA chip-ID: 1d57:0008 cla
ss-ID: 0301                             
Device-3: 1-3:8 info: JMicron / JMicr
on USA JM20329 SATA Bridge
type: Mass Storage driver: usb-stor
age interfaces: 1 rev: 2.0
speed: 480 Mb/s power: 2mA chip-ID:
152d:2329 class-ID: 0806
serial: <filter>
Device-4: 1-4:4 info: Validity Sensor
s VFS Fingerprint sensor
type: <vendor specific> driver: N/A
interfaces: 1 rev: 1.1 speed: 12 Mb/s
power: 100mA chip-ID: 138a:0010 cla
ss-ID: ff00 serial: <filter>            
Device-5: 1-5:5 info: Microdia Integr
ated_Webcam_HD type: Video
driver: uvcvideo interfaces: 2 rev:
2.0 speed: 480 Mb/s power: 500mA
chip-ID: 0c45:6a05 class-ID: 0e02
Device-6: 1-6:6 info: Realtek RTS5129
Card Reader Controller
type: <vendor specific> driver: rts
interfaces: 1 rev: 2.0 speed: 480 M
b/s power: 500mA chip-ID: 0bda:0129
class-ID: ff00 serial: <filter>
Device-7: 1-8:7 info: Intel Bluetooth
wireless interface type: Bluetooth
driver: btusb interfaces: 2 rev: 2.
0 speed: 12 Mb/s power: 100mA
chip-ID: 8087:0a2a class-ID: e001
Hub-2: 2-0:1 info: Super-speed hub po
rts: 6 rev: 3.0 speed: 5 Gb/s           
chip-ID: 1d6b:0003 class-ID: 0900
System Temperatures: cpu: 42.0 C pch:
41.0 C mobo: 41.0 C
Fan Speeds (RPM): cpu: 0
Processes: 230 Uptime: 2h 1m wakeups:
1 Init: systemd v: 249 tool: systemctl
Compilers: gcc: 11.1.0 Packages: 1405
pacman: 1385 lib: 392 flatpak: 10
snap: 10 Shell: Zsh v: 5.8 default: B
ash v: 5.1.12 running-in: konsole
inxi: 3.3.11```

That’s an AUR package. Try rebuilding it.

Will i have to re-setup it after rebuilding?
And by rebuilding do you mean removing it and reinstalling it from the gui installer?

No, not normally.

You don’t need to remove it. Just reinstall it. It’s a package that normally gets installed by compiling it on your local system, unless you installed the -bin package.

The update probably caused it to no longer be compatible with your local system libraries, so rebuilding it against the newer libraries might solve the problem. But that won’t work with the -bin version, of course.

1 Like

Sorry i’m not much aware of the aur technicalities
Can you please let me know the command/process for rebuilding it?

Then you should not use AUR build scripts.

AUR packages may cease function after system update - this is normal.

You rebuild the package the same way you did when building it the first time.

pamac build pkgname
1 Like
pamac build jellyfin

But do not pick jellyfin-bin, because that’s the binary version.


  • pamac will tell you that the package will conflict with the one you have installed and will offer you to replace it. Accept that replacement.

  • The package will be compiled on your local system, but you only have 4 GiB of RAM, so be prepared for your system to be busy (and possibly unusable) for quite a while.

1 Like

Hello, I also use jellyfin server and faced the same problem

Jellyfin (10.7) isn’t working on the latest (6.x) dotnet runtime, I’ve solved installing from the AUR aspnet-runtime-bin and dotnet-core-5.0-bin,

dotnet-core-5.0-bin is a split package

In this case rebuilding from source as suggested by other can’t work, another solution is to switch to jellyfin-git

The error message is truncated so we can’t see it


If you are using pamac gui (add and remove software) and are not comfortable using cli then just find jellyfin in pamac gui and select build, it will rebuild it

1 Like

Yeah I generally don’t but there wasn’t another easier way to get going with jellyfin

Thanks for letting me know, I am not a power user and use my laptop for basic tasks.

Thank you for the help
I tried this but rebuilding kept giving me an error regarding something ‘yarn’ mid way while building it, unfortunately I couldn’t copy it.

Sorry wasn’t aware it got truncated
Thanks for the advice the regular package kept giving me a build error,
I installed the git version and now everything works flawlessly.

Thank you so much for giving your time to help me
@Aragorn @linux-aarhus @sawdoctor @Lolix
I appreciate it a lot.

From one of the post of the AURweb page I linked:

I had nodejs 17 (current stable). I installed the nodejs-lts-fermium package (nodejs 14) and it worked again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.