Jdk-openjdk and jre-openjdk are in conflict (solution doesn't work)

I have the same issue described here: Jdk-openjdk and jre-openjdk are in conflict #2 and the “solution” doesn’t work for me. It would make sense to comment on that thread, but apparently you want me to create a new thread about the exact same topic instead, so here I am.

I did “sudo pacman -Syu jdk-openjdk” but I still get the same error at the end:

error: failed to prepare transaction (conflicting dependencies)
:: jdk-openjdk and jre-openjdk are in conflict

What should I do?

Remove jre-openjdk then install jdk-openjdk.

1 Like

The linked solution does work

I suggest you run the command without the -u ( --upgrade ) option


pamac install jdk-openjdk --no-upgrade

[arch-announce] Incoming changes in JDK / JRE 21 packages may require manual intervention


It is a common problem with the last update, the solution that we have applied to several computers from a group is to remove the conflicting packages, update and if necessary reinstall them

pamac remove jre-openjdk

pamac update

pamac install jre-openjdk

All previous recommendation listed dated on before 11/16/2023 have failed and each recommendations brake other depencies. HELP!

What is the output from

pacman -Qs jdk

install (8):
kdsoap-qt5 2.1.1-2 (Replaces: kdsoap) extra 432.6 kB
kuserfeedback5 1.3.0-4 (Replaces: kuserfeedback<5.245) extra 465.0 kB
js115 115.4.0-2 extra 12.3 MB
kirigami-addons5 0.11.0-6 (Replaces: kirigami-addons<0.11.75) extra 152.7 kB
libqaccessibilityclient-qt5 0.5.0-2 (Replaces: libqaccessibilityclient) extra 75.0 kB
kdsoap-qt6 2.1.1-2 extra 470.0 kB
libdisplay-info 0.1.1-3 extra 102.6 kB
libei 1.1.0-1 extra 102.4 kB
To downgrade (1):
kpeoplevcard 0.1-2 (0.1+r38.32d50a9-1) extra 18.2 kB
To remove (7):
libkipi 21.12.3-1
kalarmcal 21.12.3-1
kpeoplevcard 0.1+r38.32d50a9-1 extra
libqaccessibilityclient 0.4.1-2 (Conflicts With: libqaccessibilityclient-qt5)
kirigami-addons 0.11.0-2 (Conflicts With: kirigami-addons5)
kuserfeedback 1.2.0-1 (Conflicts With: kuserfeedback5)
kdsoap 2.1.1-1 (Conflicts With: kdsoap-qt5)

Total download size: 2.7 GB
Total installed size: 153.7 MB
Total removed size: 7.1 MB

Apply transaction ? [y/N]

Transaction cancelled.

I had a similar issue. I had all of these on my system:

  • jre-openjdk-headless
  • jre-openjdk
  • jdk-openjdk

Uninstalling any of them did not work. Uninstalling all of them did not work because they were required by several programs. Explicitly re-installing any of them did not work. The only solution was to first uninstall all programs that require Java, then uninstall all openjdk packages, then re-install jdk-openjdk, then re-install the programs requiring Java.

You could’ve done this:

sudo pacman -Rdd jre-openjdk-headless jre-openjdk
sudo pacman -Sy jdk-openjdk
sudo pacman -Syu
1 Like

I had the same issue as the original poster - This worked for me.

You have my thanks!

1 Like