Jasper Lake HD Audio recognized, but no sound... as usual

Well, I left Ubuntu because nobody over there could get sound working on my laptop. SO here I am in Manjaro and only Kernel 5.15 even shows the soundcard. I’ve tried out the other kernels (I dig Manjaro’s cool tool for installing/removing kernels). They don’t show anything at all. But in 5.15 it shows up as “inactive” with the profile “off” and there is no “on” option in the drop down menu.

If I run alsamixer, it doesn’t load the right chip. I can hit F6 and load the sof-hda-dsp card showing the chip name of Intel Jasperlake HDMI. But I cannot get any audio to come out of the machine.

If I load VLC and play a video, I see the program listed under Playback Streams. I don’t get any errors and the video plays smoothly (just with no audio). Under the Audio menu in VLC, under Audio Device it just shows Dummy Output.

So I don’t show any active cards in System Settings > Audio and there is no “on” option for the Inactive Card called Jasper Lake HD Audio.

I dual boot Windows and Linux on this laptop and Windows has no problem playing audio. So it isn’t as if the Bios is set wrong.

I was bored with Ubuntu so I don’t mind changing distros. But now I have the unpredictable spontaneous dead touchpad, spontaneous keyboard key repeats that lock up the system completely, etc on top of no sound. The camera doesn’t work either. Didn’t work under Ubuntu either. Works fine in windows. So I have some bugs to fix. This is sort of fun. But I would really just like to have a laptop that works without using Windows…This laptop is less than a year old. It is some Chinese brand.

Just to note, I have a USB audio interface, a Behringer UCA202, that works fine in Linux for sound. So I can at least plug headphones into that device. When I plug it in, the System Settings Audio updates instantly, showing it as both a playback and recording device. Works great!

So why can Linux work a semi-obscure USB audio interface and not a stock on-the-motherboard intel card?

HELP! Is there a command to turn the sound profile ON for the inactive card listed in settings?

Remember - Windows is the defacto standard used when creating drivers for hardware.

Always look for Linux compatibility when buying the latest and greatest hardware - that means doing some research before buying this new fancy laptop.

I have been using an USB with Manjaro and taking it with me when I am not sure of the compatibility. I usually ask in the shop if I am allowed to test the compatibility before I decide to buy - and if they are in business they are usually forthcoming.

Linux != Windows so working with Windows is not a good parameter to judge a Linux by.

Out of curiosity I took a look at what Intel call Jasper Lake - and from what I see it seems to have been created for low-cost devices - not implying anything - and such devices are built with Windows in mind.

Some of the predecessors in that category didn’t work well with Linux either.

I am a retired member of the Manjaro team and a short while I was serving the community with low-cost devices which needed some special care and kernel modules to support either the touchpad or the wifi - so I know first-hand how tricky a low-cost winbook can be in terms of running Linux.

The only reason I brought up Windows was to demonstrate that the bios was set correctly for the sound system to work at least in Windows. If the bios was wrongly set, neither Windows nor Linux could make the connection between the driver and the actual hardware layer of the machine.

This is an inexpensive laptop. I bought it because it was well reviewed and it does perform admirably for a sub-$400 laptop. With 12 GB of RAM, it runs windows quite smoothly and of course Linux runs ridiculously fast too. The inexpensive Celeron still has 4 cores so it digests complicated stuff like video creation rather well. It actually works better for video editing in Linux (I just use the USB interface for sound) as Linux only eats up less than 2 GB running Plasma with Openbox. Firefox eats up 600 MB, pushing it to 2.5 GB of RAM while doing THIS. But that still leaves 11.5 GB of RAM ready to use. At this price point, getting 12 GB of RAM is rare. That’s one reason I bought this laptop.

The other reason is it’s metal body and backlit keypad. It is built to last and the battery life is phenomenal.

So not having sound working in Linux is kind of a trade-off. I could return the laptop for incompatibility, but I just like it too much to do that. Hopefully someone will hammer out these basic soundcards in a future Kernel or provide a suitable Linux driver at some point in the future as I am sure these inexpensive laptops will continue to flood the market.

I also have found no problems loading any Linux distro on this thing (except sound). The advanced bios lets me easily select what I want to boot and after install, Grub does a fine job splitting the Windows mess from the Linux partition. Only in one case I had to reinstall Grub from a live boot to get my Linux partition to boot. Other installs went super smooth and fast and just worked from the start.

I have some confusion regarding the sound system architectures available to Linux. What is better? ALSA? Pulse Audio? Pipe Wire? Jack? Some combination of them? I don’t quite understand the differences let alone any advantages/weaknesses of these.

I do find it odd that only the 5.15 Kernel at least names the device correctly in settings. I wonder if there is some config file I need to edit to change a 0 to a 1 on some line of code to activate that profile.

I went through an extensive debug process with Ubuntu and never made progress. The notes to that guided conversation are at the launchpad Ubuntu site as question 701751.

This troubleshooting process is noted at community help page for Ubuntu called SoundTroubleshootingProcedure.

Sorry, but I can’t post URLs here.

Some handy details so you can see what I am working with:
Manufacturer: ALLDOCUBE
Product Name: i1405S

Operating System: GNU/Linux
Architecture: x86_64
Processor: x86_64
SMP Enabled: Yes

Soundcards recognised by ALSA
[sofhdadsp ]: sof-hda-dsp - sof-hda-dsp

PCI Soundcards installed in the system
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Device [8086:4dc8] (rev 01)
DeviceName: Onboard - Sound

Loaded sound module options
Module: snd_soc_skl_hda_dsp

Sysfs card info
Card: /sys/class/sound/card0
Driver: /sys/bus/platform/drivers/skl_hda_dsp_generic

HDA-Intel Codec information
Codec: Intel Jasperlake HDMI

These were the responses based on the Ubuntu trouble shoot guide. I can try to run them again in Manjaro, but the output would be similar if not identical and that is IF I can figure out how to run the equivalent commands in Manjaro.

because this “obscure” device does follow the specifications and this onboard-device is an exotic chinese-cracker that doesn’t. that sounds crude but not every hardware is supported and if you give so few information no-one will ever be able to assist in any way.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


I did figure out the physical hardware names for the Audio stuff. That should be universal to most Linux distros.

   description: Multimedia audio controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 1f.3
   bus info: pci@0000:00:1f.3
   logical name: card0
   logical name: /dev/snd/controlC0
   logical name: /dev/snd/hwC0D2
   logical name: /dev/snd/pcmC0D1p
   logical name: /dev/snd/pcmC0D2p
   logical name: /dev/snd/pcmC0D3p
   version: 01
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi bus_master cap_list
   configuration: driver=sof-audio-pci-intel-icl latency=32

It seems to me that logical name: /dev/snd/hwC0D2 would be the basic audio input and output device, and the rest would be related to HDMI connections.

I tried to post the output of inxi --admin --verbosity=7 --filter --no-host --width but this forum thinks there is an URL in there somewhere. I edited it down to where it would post successfully.

Specifically I had to modify the following line to get rid of the dot org:

Display: x11 server: X Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")

The rest is in order of the output:

Kernel: 5.15.49-1-rt47-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-rt-x86_64
root=UUID=02143592-696a-497e-b060-155a6703cfd8 rw quiet splash apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm:
1: LightDM v: 1.30.0 note: stopped 2: SDDM Distro: Manjaro Linux
base: Arch Linux
Type: Laptop System: ALLDOCUBE product: i1405S v: N/A
Mobo: ALLDOCUBE model: ALLDOCUBE serial:
UEFI: American Megatrends LLC. v: Z362D.2112031.003.2133 date: 12/30/2021
ID-1: BAT0 charge: 38.0 Wh (100.0%) condition: 38.0/38.0 Wh (100.0%)
volts: 7.6 min: N/A model: Intel SR 1 SR Real Battery type: Unknown
serial: status: full
RAM: total: 11.51 GiB used: 2.67 GiB (23.2%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
Info: model: Intel Celeron N5100 bits: 64 type: MCP arch: Tremont
built: 2019 process: Intel 10nm family: 6 model-id: 0x9C (156) stepping: 0
microcode: 0x24000023
Topology: cpus: 1x cores: 4 smt: cache: L1: 256 KiB
desc: d-4x32 KiB; i-4x32 KiB L2: 1.5 MiB desc: 1x1.5 MiB L3: 4 MiB
desc: 1x4 MiB
Speed (MHz): avg: 2543 high: 2699 min/max: 800/2800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2457 2: 2587 3: 2699
4: 2430 bogomips: 8908
Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc
cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
est flexpriority flush_l1d fpu fsgsbase fxsr gfni ht hwp hwp_act_window
hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt
lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr
nonstop_tsc nopl nx pae pat pbe pclmulqdq pdcm pebs pge pln pni popcnt pse
pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap
smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall
tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip
vme vmx vnmi vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt xsaves
xtopology xtpr
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
Type: srbds status: Vulnerable: No microcode
Type: tsx_async_abort status: Not affected

Device-1: Intel JasperLake [UHD Graphics] driver: i915 v: kernel arch: Gen11
process: Intel 10nm built: 2019-21 ports: active: eDP-1
empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:4e61
class-ID: 0300

Device-2: Realtek USB Camera type: USB driver: uvcvideo bus-ID: 1-5:2
chip-ID: 0bda:5830 class-ID: 0e02

Monitor-1: eDP-1 model: BOE Display 0x09de built: 2020 res: 1920x1080
hz: 60 dpi: 158 gamma: 1.2 size: 309x174mm (12.17x6.85") diag: 355mm (14")
ratio: 16:9 modes: 1920x1080

Device-1: Intel Jasper Lake HD Audio vendor: Realtek
driver: sof-audio-pci-intel-icl
alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
chip-ID: 8086:4dc8 class-ID: 0401
Sound Server-1: ALSA v: k5.15.49-1-rt47-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: no
Sound Server-4: PipeWire v: 0.3.55 running: yes
Device-1: Intel Wi-Fi 6 AX201 160MHz driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:4df0 class-ID: 0280
IF: wlo1 state: up mac:
IP v4: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: link
Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-8:4
chip-ID: 8087:0026 class-ID: e001
Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
Message: No logical block device data found.
Message: No RAID data found.
Local Storage: total: 357.85 GiB used: 225.51 GiB (63.0%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: SSD-HYX-1HAH19-256-SN312
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
type: SSD serial: rev: A2.0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 type: USB model: Multiple Card Reader
size: 119.38 GiB block-size: physical: 512 B logical: 512 B type: N/A
serial: rev: 1.00 scheme: MBR
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Message: No optical or floppy data found.
ID-1: / raw-size: 93.13 GiB size: 91.11 GiB (97.83%) used: 20.39 GiB (22.4%)
fs: ext4 dev: /dev/sda5 maj-min: 8:5 label: N/A
uuid: 02143592-696a-497e-b060-155a6703cfd8
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 58.7 MiB (61.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: SYSTEM
uuid: F60F-8BCA
ID-3: /run/media/darkstarone/58F6103DF6101DB6 raw-size: 144.35 GiB
size: 144.35 GiB (100.00%) used: 117.8 GiB (81.6%) fs: ntfs dev: /dev/sda3
maj-min: 8:3 label: N/A uuid: 58F6103DF6101DB6
ID-4: /run/media/darkstarone/9C33-6BBD raw-size: 119.36 GiB
size: 119.36 GiB (100.00%) used: 87.26 GiB (73.1%) fs: exfat dev: /dev/sdb1
maj-min: 8:17 label: N/A uuid: 9C33-6BBD
Alert: No swap data was found.
ID-1: /dev/sda2 maj-min: 8:2 size: 16 MiB fs:
label: N/A uuid: N/A
ID-2: /dev/sda4 maj-min: 8:4 size: 900 MiB fs: ntfs label: Recovery
uuid: 96A812ACA8128ABF
Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 1-5:2 info: Realtek USB Camera type: Video driver: uvcvideo
interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:5830
class-ID: 0e02
Device-2: 1-6:3 info: Alcor Micro Multi Flash Reader type: Mass Storage
driver: usb-storage interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA
chip-ID: 058f:6366 class-ID: 0806 serial:
Device-3: 1-8:4 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
class-ID: e001
Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 270 Uptime: 1d 16h 32m wakeups: 1 Init: systemd v: 251
default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
Packages: 1609 apt: 0 pacman: 1595 lib: 376 flatpak: 14 Shell: Zsh v: 5.9
running-in: konsole inxi: 3.3.19

I have also run aplay -L
Discard all samples (playback) or generate zero samples (capture)
Rate Converter Plugin Using Libav/FFmpeg Library
Rate Converter Plugin Using Samplerate Library
Rate Converter Plugin Using Speex Resampler
JACK Audio Connection Kit
Open Sound System
PipeWire Sound Server
PulseAudio Sound Server
Plugin using Speex DSP (resample, agc, denoise, echo, dereverb)
Plugin for channel upmix (4,6,8)
Plugin for channel downmix (stereo) with a simple spacialization
Default ALSA Output (currently PipeWire Media Server)
USB Stream Output

just to update, I ran inxi -Aa again. The Sound Server 1 changed to a different version. The rest remained the same.
Device-1: Intel Jasper Lake HD Audio vendor: Realtek
driver: sof-audio-pci-intel-icl
alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
chip-ID: 8086:4dc8 class-ID: 0401
Sound Server-1: ALSA v: k5.15.55-1-MANJARO running: yes
Sound Server-2: JACK v: 1.9.21 running: no
Sound Server-3: PulseAudio v: 16.1 running: no
Sound Server-4: PipeWire v: 0.3.55 running: yes

Searching Manjaro forum for ‘jasper lake’ only shows one other discussion about no audio
No sound only "Dummy Output" on Huawei Matebook D 15 (Intel)
But I know there are other ‘chromebook’ type devices with earlier generations of Intel *Lake codecs having similar problems

I have never heard of ALLDOCUBE before, but there are 2 Linux hardware scans online for different models: linuxhardware.org - ALLDOCUBE

Manufacturer’s website specifications advise:

Alldocube GT Book Parm – Alldocube Global
Microphone - Supported
Sound - Dual Speakers

Headphone Jack - 3.5mm

Modern laptops usually have digital array microphones (so Cortana can hear you on other OS) that
require Sound Open Firmware drivers to work
Audio device is using SOF driver sof-audio-pci-intel-icl
(data in post #3 was showing a different driver snd_soc_skl_hda_dsp)

If you do not want to use internal microphones, you could try this command to force use of the driver snd_hda_intel that might have better support for audio playback:

sudo tee /etc/modprobe.d/dspcfg.conf <<< 'options snd-intel-dspcfg dsp_driver=1'

If I run alsamixer, it doesn’t load the right chip

If alsamixer command does not include the card number for hardware device, alsamixer will only show virtual audio controls for the default sound server (PulseAudio or Pipewire)
To go direct to onboard audio controls in alsamixer using the card number option:

alsamixer --card=0

Or use amixer --card=0 to get information in text format if you need to post information here
(screenshots of alsamixer are usually incomplete and not good for troubleshooting)

The Sound Server 1 changed to a different version

inxi data for ALSA does not show the version number of ALSA packages (v1.2.7.2)
v: k5.15.55-1-MANJARO is the kernel version number