It seems my ~/.profile is not being used anymore?

must be after some update. anything I can do about it?

Please search the forum. That question has already been asked and answered many times.


1 Like

then your search sucks:

the only thing I could find (I did search beforehand btw) is about .bash_profile, when zsh was the default shell which it doesn’t seem to be for me

1 Like

After recent update for lightdm, system is not applying configuration settings in ~/.profile including: export QT_QPA_PLATFORMTHEME="qt5ct"
for QT theme

If there is no response to this command


Forum users have posted 3 different ways to resolve this:

  1. Copy configuration in ~/.profile to ~/.bash_profile


  1. Configure ~/.bash_profile to read ~/.profile
    tee -a ~/.bash_profile <<< "[[ -f ~/.profile ]] && . ~/.profile"


  1. create a symlink for ~/.profile to ~/.xprofile
    cd $HOME; ln -s .profile .xprofile

Xfce theming theming issues with some applications green others blue

[Stable update]-2024-03-06 - post #31

1 Like

the first 2 solutions are suboptimal because that would run .profile each time a shell is opened. I for instance have a looping script in it that also happens to create output. Or I clear a ~/tmp folder in it, I dont want that each time I open a shell. There’s probably a million other reasons.

this sure has to do with “do you want to replace manjaro_bash with bash?”

I read in the Ubuntu stackexchange that .profile is ignored one .bash_profile exists. Why? I don’t know. They apparently fullfill different purposes.

also I would probably prefer to just use .xprofile than sym linking, seems like a cleaner solution to me

This is not true according the the Bash reference manual. Only interactive login shells read ~/.bash_profile:

When you start an interactive shell that is not a login shell:

No, it was changed by Arch because of this report for LightDM:

In short, you can use ~/.xprofile, as you already mentioned in your last post, source it in ~/.bash_profile or symlink it, as already mentioned above.

No it doesn’t.

Despite all the “why don’t you search” type answers, I can confirm this is a new regression. Worked find for me until very recently, no changes in my config. So digging up old answers is unlikely to help.

For the record I fixed this via the route of having my .xprofile source my .profile… I originally had it source my .bashrc (which already sources my .profile) but that didn’t work, I guess maybe I have a short in there somewhere for things which aren’t actually bash?

Anyway, now it works and maybe this helps!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.