Issues with Xmg core 15 amd 2021

Hello everyone,
Yesterday i received this laptop and i immediately installed Manjaro KDE. I have different issues:

  • first of all, the LCD brightness doesn’t change; the fn keyboard works (as i can see the progress bar) but no response from the screen. (i tried to change the grub line but maybe i wrote the wrong line).
  • Ethernet cable not recognized (in the live usb it worked).
  • Did i have to setup something since i have hybrid laptop (AMD ryzen 7 + Nvidia geforce 3060 mobile). Manjaro managed to install the video-hybrid. I installed optimus manager and optimus manager qt.

Thanks for your patience! :slight_smile:


I own “Illegear Onyx V Ryzen” (which is the Malaysian equivalent of XMG Core 15)
AMD Ryzen 4800H, Nvidia GeForce GTX 1650.

Last week I installed Manjaro 21.0.5 (Dual boot mode with Windows 10 installed on a separate SSD)

Ethernet cable is detected and works for me. However, there are issues with backlight brightness control.


Brightness control worked perfectly (both keyboard shortcut and brightness bar) on the live CD. But after installation, brightness controls stopped working.

What I tried:

  1. Updated /etc/default/grub file with following values
    GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=video"
  2. update-grub
  3. reboot

Observations after the change:

  1. Brightness control works
    a) If my last exit from Windows 10 was a restart and login to Manjaro immediately after the update-grub and reboot
  2. Brightness control never works
    a) If I reboot Manjaro without an update-grub
    b) Or if I shut down Windows and log in to Manjaro

So if I happened to log in to Windows 10, I always do a reboot instead of a shutdown and do an update-grub before leaving Manjaro.

This works so far. But do not know the root cause.

Thanks for helping me. I tried as you suggest with no result.

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX="acpi_osi=Linux acpi_backlight=video"

Does the GRUB_CMDLINE_LINUX_DEFAULT change something?

Ethernet works during liveUSB and after the reboot. After the second reboot it stopped working.

EDIT: Ethernet works if i shutdown then turn on the laptop. If i restart (or reboot from terminal) it doesn’t