Issues with wired network connection in manjaro. Intel igc kernel issue (error -13) Driver: N/A

Hello everyone!
I’m totally new to the Manjaro and Linux so please don’t be so hard to me =)

I’m having an issue with the Network.
I have 2 devices here - one is wired adapter and wifi adapter.
And wifi is working (somehow), but wired connection is not available in any way.
I tried to find a solution using this forum, but no luck so far.
I have this message “igc: probe of 0000:03:00.0 failed with error -13” as main clue, but I have no idea what is -13 error is and where I can find any documentation for this.

Tech info:

lspci -nnk

03:00.0 Ethernet controller [0200]: Intel Corporation Ethernet Controller I225-V [8086:15f3] (rev 03)
	Subsystem: Gigabyte Technology Co., Ltd Device [1458:e000]
	Kernel modules: igc
04:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
	Subsystem: Intel Corporation Wi-Fi 6 AX200NGW [8086:0084]
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

dmesg shows this:

[  865.638962] Intel(R) 2.5G Ethernet Linux Driver
[  865.638963] Copyright(c) 2018 Intel Corporation.
[  865.639108] igc 0000:03:00.0: PTM enabled, 4ns granularity
[  868.168697] igc: probe of 0000:03:00.0 failed with error -13

As far as I can see I’m using igc kernel.
When I tried to load/reload igc via **modprobe -r ** , I receive the same issue in the dmesg.

ip link show

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: wlp4s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP mode DORMANT group default qlen 1000
    link/ether 68:54:5a:ab:0a:95 brd ff:ff:ff:ff:ff:ff

inxi -Fxzc0

  Kernel: 5.15.50-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    Desktop: GNOME v: 42.2 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: B560M AORUS PRO AX v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: B560M AORUS PRO AX v: x.x
    serial: <superuser required> BIOS: American Megatrends LLC. v: F8
    date: 08/31/2021
  Info: 6-core model: 11th Gen Intel Core i5-11400 bits: 64 type: MT MCP
    arch: Rocket Lake rev: 1 cache: L1: 480 KiB L2: 3 MiB L3: 12 MiB
  Speed (MHz): avg: 800 high: 801 min/max: 800/4400 cores: 1: 801 2: 801
    3: 801 4: 801 5: 801 6: 801 7: 800 8: 800 9: 800 10: 801 11: 801 12: 801
    bogomips: 62232
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel RocketLake-S GT1 [UHD Graphics 730] vendor: Gigabyte
    driver: i915 v: kernel arch: Gen12.1 bus-ID: 00:02.0
  Device-2: NVIDIA TU117 [GeForce GTX 1650] driver: nvidia v: 515.57
    arch: Turing bus-ID: 01:00.0
  Display: x11 server: v: with: Xwayland v: 22.1.2 driver:
    X: loaded: nvidia gpu: i915,nvidia resolution: 1: 2560x1440~60Hz
    2: 1920x1080~72Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1650/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.57 direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA driver: snd_hda_intel v: kernel bus-ID: 01:00.1
  Sound Server-1: ALSA v: k5.15.50-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Intel Ethernet I225-V vendor: Gigabyte driver: N/A port: N/A
    bus-ID: 03:00.0
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-14:12
  Report: rfkill ID: hci1 rfk-id: 3 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
    driver: btusb v: 0.8 bus-ID: 1-6.4:7
  Report: ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: N/A
  Local Storage: total: 1.14 TiB used: 851.74 GiB (73.1%)
  ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 250GB size: 232.89 GiB
  ID-2: /dev/sdb vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB
  ID-1: / size: 219.51 GiB used: 69.87 GiB (31.8%) fs: ext4 dev: /dev/sda1
  Alert: No swap data was found.
  System Temperatures: cpu: 39.0 C mobo: N/A gpu: nvidia temp: 58 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
  Processes: 348 Uptime: 1h 2m Memory: 31.15 GiB used: 3.09 GiB (9.9%)
  Init: systemd Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: 1303
  Shell: Zsh v: 5.9 inxi: 3.3.19

Issue appeared after last package updates (10 July).

Thank you in advance!

Are you dual booting with windows?
Does same happen on newer, a la 5.18, kernel?
Does adding kernel parameter pcie_aspm=off help?

EDIT: Another bug report: Bug#996008: Bug #996008: i225 NIC no longer recognized after 11.1 point release

1 Like
$ LANG=C errno 13
EACCES 13 Permission denied

Not sure, but it looks like the BIOS blocks the probe of the pci address. No idea why.

You can add debug, to see more details at dmesg:

sudo modprobe -vr igc
sudo modprobe -v igc debug=16

@megavolt Thank you !

I didn’t know about errno because I have to download a package to be able to “see” it - Thanks, now I know more.

About “more details” :
I agree with you that if -13 is permission denied than there is a BIOS issue.
So I have to look here…

I don’t know why but after I did what you suggested

sudo modprobe -vr igc
sudo modprobe -v igc debug=16

I saw that igc was reloaded and finally can “access” to the device:

dmesg | grep igc output (after PC reboot - I decided to reload system to verify will device be available after reboot):

[    5.668806] igc 0000:03:00.0: PTM enabled, 4ns granularity
[    5.716208] igc 0000:03:00.0 (unnamed net_device) (uninitialized): PHC added
[    5.740536] igc 0000:03:00.0: 4.000 Gb/s available PCIe bandwidth (5.0 GT/s PCIe x1 link)
[    5.740538] igc 0000:03:00.0 eth0: MAC: d8:5e:d3:5e:72:92
[    6.400558] igc 0000:03:00.0 enp3s0: renamed from eth0
[   10.340844] igc 0000:03:00.0 enp3s0: NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX

From the question till your answer the PC was turned ON and was used for work without Ethernet usage. Also I didn’t open PC physically.

Now I can work with Ethernet device as before (so my question is answered), but I will add info here when will figure out why it’s happened.

Than you very much!

@zbe Thank you for the answer!

  1. I don’t have a dual boot (only Manjaro on SSD drive).
  2. Because I’m a new in Manjaro, I can’t say for this - I really don’t know how to switch to other kernel manually.
  3. Could you specify where I should add this parameter ? in grub launch parameters?

It seems it started working magically so no further work is necessary. :man_shrugging: :slight_smile:

As for 2. and 3.: There is enough info on forum and other places about changing kernels and adding kernel parameters, so it’s not hard to find it. For future if nothing else.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.