Issues with screen sharing

While trying to screen share(manjaro + xfce on any platform), I am only able to share the “Entire Screen” rather than an application window. I was previously using Ubuntu+Gnome in which screen sharing worked fine.


:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

  3. Which application are you talking about? VNC? Zoom? Skype? Something else entirely?


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel you have, …

1 Like


Which application?

1 Like

Sorry for not being clear. I am facing similar issues across all applications(web browser based and others like Deskreen, zoom etc)

As for the other info :

  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=ce5a063c-bf39-4d25-849e-cecd759c0fa9 rw quiet udev.log_priority=3 
  Desktop: N/A wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 

      Info: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
      arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10) 
      microcode: E0 L2 cache: 6 MiB bogomips: 28808 
      Speed: 859 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 859 2: 919 3: 790 
      4: 930 5: 729 6: 1170 7: 1019 8: 723

      Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel 
      bus ID: 00:02.0 chip ID: 8086:5917 
      Device-2: Realtek EasyCamera type: USB driver: uvcvideo bus ID: 1-8:3 
      chip ID: 0bda:58ea serial: <filter> 
      Display: x11 server: X.Org 1.20.10 driver: loaded: intel,modesetting 
      alternate: fbdev,vesa display ID: :0.0 screens: 1 
      Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
      s-diag: 414mm (16.3") 
      Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
      diag: 389mm (15.3") 
      OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.3.3 
      direct render: Yes

I’m facing the same problem.

Since a couple of weeks ago I’ve seen some people having problems with pipewire. I haven’t noticed any problems because of it until this week, in my case I can´t share Desktop on Microsoft Teams. I have seen the same problem during the last update, and because some folks on the AUR comments about problems with Teams pipewire dependencies or broken packages, that results in a number of post as well even having problems so they can’t get Screen Sharing work in any application.

Please excuse my english, i’m new here!

Kernel 5.10, GNOME on Xorg Session

Same problem here!
I could never use the WebRTC screen sharing of Firefox, but before the last update (installed it yesterday) at least with Chromium screen sharing worked under Wayland.

But now neither with Firefox nor with Chromium screen sharing with pipewire works anymore…

I would like to provide additional information, but I can’t find any logs that Firefox produces. If you have any suggestions feel free to tell me how to do it