Issues with multi-monitor setup

I’m having this issue with my multi-monitor setup that’s been driving me up the wall lately.
So I have a dualboot system with Manjaro as my distro for every day tasks (for which I only need one monitor), and Linux Mint for work.
On my Linux Mint I use two monitors for work, one’s on a VGA cable (native resolution of 1366x768), the other one (the main monitor, native resolution 1920x1080) is on DP. Intel IGP is driving those two monitors.
Now on Linux Mint I do get occasional issues when the main monitor would be switched over to the VGA monitor, but with a few adjustments it’s easy to fix it, even if it’s a bit annoying to be required to do this.
On Manjaro however, most of the time when I boot into it, after I resume from suspend, the monitor setup is screwed.
What ends up happening is that it switches the main monitor to the VGA one (even though I’ve disabled it by switching off the “Active” setting in the Display settings panel), and the DP monitor uses the wrong resolution (1440x900), and the native resolution is not made available in the list.
Now I can easily switch off the VGA monitor fro the settings so it reverts back to the DP monitor, but the resolution problem is a lot harder to fix.
Sometimes when I would switch the DP monitor to a lower resolution (like 800x600 for example), then afterwards the native resolution would be made available, but not always.
I’ve also tried doing some xrandr trickery to no avail:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode DP1 1920x1080_60.00
xrandr --output DP1 --mode 1920x1080_60.00

It doesn’t seem to be able to change the resolution, but I didn’t catch the exact message it outputs.
Restarting Cinnamon doesn’t seem to help at all.
The only thing that helps is to restart the PC and then boot back in, and then I’m able to switch to the native resolution.

Could anyone guide me into what I need to do to keep those settings permanent and to prevent all this from happening? (switching the active monitor, not disabling the VGA monitor, no native resolution available)

Alright, issued the xrandr commands from above, and got this error:

xrandr: Configure crtc 0 failed

Taking a look into the Display settings panel, I see the resolution has been added there as well, but I get a similar error message, this time being CRTC 62 instead (can’t attach screenshots to show full message)

So I’ve tried following a forum post off Archlinux (I’m not allowed to link to it by the forum software)
Mentioned using decode-edit and obtaining edid data through
xrandr --props

After getting the proper mode line for my monitor’s native resolution and the EDID data, I’ve issued these commands:

xrandr --newmode "1920x1080_60.00" 148.500  1920 2008 2052 2200  1080 1084 1089 1125  +HSync +VSync
xrandr --addmode DP1 1920x1080_60.00
xrandr --output DP1 --mode 1920x1080_60.00

First time I tried issuing the commands again, Cinnamon crashed/froze at the 2nd line.
Restarted Cinnamon, and of course now both monitors are active again, and now I only have two resolutions available for the DP monitor (1024x768 and 800x600)

Is there any way to disable VGA output all together on this OS so it would stop activating the VGA monitor?

In the meantime I’ll try to boot with this Xorg conf file, hopefully it’ll load the correct edid file so it would (hopefully) always get the correct native resolution:

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option      "AccelMethod"  "uxa"
  Option      "DP-1"   "MonitorDP1"
  Option      "CustomEDID" "DP1:/SSD-Storage/edid.bin"
  Option      "UseEDID" "true"

Alright, I’m still having issues, even after using the above Xorg conf file.
This time it happened after the monitor went to sleep, and I woke it up by moving the mouse.
The 2nd (VGA) monitor was enabled again, and the DP monitor was using the wrong resolution.
I had to manually disable the 2nd monitor again, and to restart two times to get back the native resolution on the DP monitor… This is a pain in the butt.

So, after looking at this thread, here’s some more info in case it helps any of you suggest anything:

  Kernel: 5.15.10-lqx1-1-lqx x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: audit=0 intel_pstate=disable BOOT_IMAGE=/boot/vmlinuz-linux-lqx
    root=UUID=a244ffca-345e-41d1-a323-518348805ff5 rw
    resume=UUID=fbf21e9d-1879-43fd-995a-4b06821d4a14 udev.log_priority=3
  Desktop: Cinnamon 5.2.7 tk: GTK 3.24.31 vt: 7 dm: LightDM 1.30.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Hewlett-Packard product: HP Compaq 8200 Elite CMT PC
    v: N/A serial: <superuser required> Chassis: type: 6
    serial: <superuser required>
  Mobo: Hewlett-Packard model: 1494 serial: <superuser required>
    BIOS: Hewlett-Packard v: J01 v02.06 date: 06/09/2011
  Message: No system battery data found. Is one present?
  RAM: total: 7.66 GiB used: 2.92 GiB (38.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i5-2400 bits: 64 type: MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2989 high: 3294 min/max: 1600/3101 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3293 2: 2079
    3: 3294 4: 3290 bogomips: 24743
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept est
    flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce
    md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts rdtscp rep_good
    sep smx ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow
    tsc tsc_deadline_timer vme vmx vnmi vpid x2apic xsave xsaveopt xtopology
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Hewlett-Packard driver: i915 v: kernel bus-ID: 00:02.0
    chip-ID: 8086:0102 class-ID: 0300
  Display: x11 server: X.Org driver: loaded: intel display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3")
    s-diag: 583mm (23")
  Monitor-1: DP1 res: 1920x1080 hz: 60 dpi: 96 size: 509x286mm (20.0x11.3")
    diag: 584mm (23")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:1c20 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.10-lqx1-1-lqx running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.45 running: no
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: f080 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 419.18 GiB used: 237.02 GiB (56.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 120GB
    size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3250312AS
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: JC47 scheme: MBR
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST3808110AS
    size: 74.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: N/A serial: <filter> rev: H scheme: MBR
  Optical-1: /dev/sr0 vendor: hp model: DVD A DH16ABSH rev: YHDD
    dev-links: cdrom
  Features: speed: 40 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 20 GiB size: 19.52 GiB (97.59%) used: 13.71 GiB (70.2%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A
    uuid: a244ffca-345e-41d1-a323-518348805ff5
  ID-2: /SSD-Storage raw-size: 75 GiB size: 73.03 GiB (97.38%)
    used: 5.39 GiB (7.4%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 6c8e9a2d-b2db-4b59-8cbf-5f024fc2679d
  ID-3: /home raw-size: 232.88 GiB size: 229.1 GiB (98.38%)
    used: 217.92 GiB (95.1%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19
    label: Home Partition uuid: 4b1f4157-2fd4-411f-b3a4-5349807b25a4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 1.78 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: fbf21e9d-1879-43fd-995a-4b06821d4a14
  ID-1: /dev/sda4 maj-min: 8:4 size: 8 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-2: /dev/sda5 maj-min: 8:5 size: 15 GiB fs: ext4 label: N/A
    uuid: 4fd71e86-4161-4d75-a790-072ef1103166
  ID-3: /dev/sdc1 maj-min: 8:33 size: 74.5 GiB fs: ext4 label: Storage
    uuid: 4fc0f0a7-cfd7-4080-b29d-2552836a8dbe
  Hub-1: 1-0:1 info: Full speed or root hub ports: 3 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.5:3 info: Lenovo Traditional USB Keyboard type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 17ef:6099 class-ID: 0300
  Device-2: 1-1.6:4 info: Lenovo Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 17ef:608d class-ID: 0301
  Hub-3: 2-0:1 info: Full speed or root hub ports: 3 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  System Temperatures: cpu: 37.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 197 Uptime: 2h 47m wakeups: 0 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.1 Packages: pacman: 1104
  lib: 336 flatpak: 0 Shell: Bash v: 5.1.16 running-in: terminator
  inxi: 3.3.12

Looking at the Xorg logfiles, it doesn’t seem like it’s using the edid file at all, it still pulls (sometimes incorrectly) the info from the monitor.
Here’s the log file for this last boot: Hastebin
Will try to get another log when this happens again.
In the meantime, can anyone suggest what I could try next?

Thank you in advance