Issues with installing Manjaro Linux on my Hard Drive

My laptop recently has decided to stop booting windows. I have tried countless ways to fix it, until I decided to give up and switch to Linux, and I chose Manjaro KDE. I love the look of it, so I tried to install it from my USB. After making sure all settings were correct(Erase entire drive, made sure the drive was correct) it throws an error about the partition? I can’t tell exactly what the error is trying to do, but I really want to install this. If anyone can help, thanks!
The error:

The Installer failed to create partition on disk [my drives name]

Create new partition(300.0MB, fat32) on /dev/sda

Job: Create new partition on ‘/dev/sda’

Command: mkfs.fat -F32 -I -v /dev/sda1

Well that’s a shame, it would have helped.

Considering even the previously installed Windows fails to boot, and the error when partitioning for Manjaro, it might be a drive issue.
What does :point_down: return from the liveUSB?

inxi -D
lsblk -af

I mean the error actually doesn’t show anything but what I listed, which is strange because I found online that some people do have error codes below. Anyway, I ran the commands and it returned this:

inxi -D                                                                                        ✔ 
  Local Storage: total: 581.68 GiB used: 0 KiB (0.0%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000LPCX-24C6HT0
    size: 465.76 GiB
  ID-2: /dev/sdb type: USB model: USB FLASH DRIVE size: 115.92 GiB
    ~  lsblk -af                                                                                      ✔ 
NAME  FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0 squash 4.0                                                              0   100% /run/miso/sfs/livefs
loop1 squash 4.0                                                              0   100% /run/miso/sfs/mhwdfs
loop2 squash 4.0                                                              0   100% /run/miso/sfs/desktopfs
loop3 squash 4.0                                                              0   100% /run/miso/sfs/rootfs
│     ntfs         LENOVO          F4ECEE71ECEE2E14                                    
│     ntfs         WINRE_DRV       B45AE03E5ADFFB56                                    
│     ntfs         LENOVO_PART     68AAE1D5AAE19FB4                                    
      vfat   FAT32 LRS_ESP         46E3-1775                                           
sdb   iso966 Jolie MANJARO_KDE_2121
│                                  2022-01-03-16-02-54-00                     0   100% /run/miso/bootmnt
│     iso966 Jolie MANJARO_KDE_2121
│                                  2022-01-03-16-02-54-00                              
      vfat   FAT12 MISO_EFI        8078-6038                                           

A partitioning error on a drive which counts 4 partitions with known filesystems… :thinking:
Would it use a MBR partition table?

LANG=C sudo fdisk -l /dev/sda

(Password from liveUSB is manjaro .)