Issues with GRUB on the unstable branch

Same here, with update of grub package it boots directly into Bios for me. To bring it back was to chroot and then downgrade to r261. Btrfs, unencrypted.
I can’t tell what is wrong with it, no significant errors, but something is wrong. The affected grub package has been reverted in repository.

As I just explained…

Meaning?

It sounds like you don’t have the latest version installed. I pushed 2.06.r322.gd9b4638c5-1 about 10 hours ago.

Same here means my machine boots into Bios after I updated grub package.
The boot into Bios happened with r322. The update was done ~3 hours ago.

Downside now is after going back I don’t have Grub selection anymore with my dual boot. I’ll fix that later. os-prober does detect my second boot option.


Edit: After a timeshift restore and a new install try of grub 2.06.r322 + all other packages it boots normal now.

This patchset.

This is the dance I always end up doing, when I loose my bootloader somehow Restore the GRUB Bootloader on Manjaro Linux. Usefull when your fresh windows install eats your grub and can not boot into your linux installation, or for some how your grub is missing · GitHub

My post was more of the info for other users spirit, not this needs to be fixed (one user is a too small sample size, but I appreciate the thought)

I also remember seeing something in the update log regarding grub, can’t remember the exact wording but here are some bullet points:

  • you need a ****64.efi
  • secure boot
  • or it will break

There are some reports about the issue of GRUB update in reddit and arch linux forum

1 Like

After this update my box acted same, so itwas going into directly bios instead of opening grub
Even when i tried to live manjaro usb stick and selecting find EFI partions menu couldnt solve
this { when i selected related efi image it was still going into bios/uefi }
I have fixed it with running a manjaro live systen , then run a console terminal and used
sudo manjaro-chroot -a
grub-install /dev/sda
update-grub
exit
and reboot

1 Like

I’ve removed 2.06.r322.gd9b4638c5-1 and reverted back to 2.06.r261.g2f4430cc0-1 for now.

This is kind’a strange.

$ grub-reboot --version
grub-reboot (GRUB) 2.06.r322.gd9b4638c5-1

My system(s) has no issue with r322.

Could this be a specific hardware issue?

3 Likes

I was wondering the same because i did the update on two installs (same machine tho) and both work as before with the 2.06.r322.gd9b4638c5-1

Dang - one of my laptops just jammed - r297 → r322 - firmware screen (it was a baremetal test of EndeavourOS - unrelated to Manjaro)

1 Like

@linux-aarhus Did it happen on second boot after install?

firmware → reboot → firmware loop

I think I remember that I was able to systemctl reboot after the upgrade (didn’t pay much attention to it) but a second reboot stalled the system in Bios. :person_shrugging:

I don’t have any issues with 2.06.r322.gd9b4638c5-1

1 Like


Got greeted by this beauty on kernel 5.19. This time I got the “out of memory” errors without trying to access the GRUB menu. I guess shutdown and reboot aren’t the same for the system, since this booted just fine yesterday, when all I did were reboots after updates.
Booted to 5.15, downgraded GRUB, and everything is back to normal (absence of “out of memory” errors, and working theme included).

I have been thinking in the same direction - thought it could be the kernel.

I dug around in the jammed laptop but I couldn’t find any hints to why grub should fail and force me into the firmware.

As this is playground and this topic already contains a reference to archlinux reddit - I thought - I test a vanilla Arch - replacing my jammed EOS.

The Arch grub has an epoch attached and there is no issues with

$ uname -r
5.19.3-arch1-1
$ grub-reboot --version
grub-reboot (GRUB) 2:2.06.r322.gd9b4638c5-1

My working Manjaro is

$ uname -r
6.0.0-1-MANJARO
$ grub-reboot --version
grub-reboot (GRUB) 2.06.r322.gd9b4638c5-1

Arch users are having issues as well:

FS#75673 - [grub] long(er) start delays after upgrading from 2.06.r261 to 2.06.r297

1 Like

I saw that - the interesting bit is that my test of EOS was working with r297 - but jammed with r322 - and no indications at all.

I checked in chroot - with mkinitcpio and grub-mkconfig - thought it could be - I don’t know - a grub to kernel that failed - but nothing I could find.

Which is why I decided to do a clean vanilla arch using an arch iso and archinstall - which is working but grub appear to have been rebuiltf - the epoch being 2 comparing to the earlier EOS on r297 - which had no epoch and now grub is epoch 2 - someone has been busy in arch camp.

uname -r           
6.0.0-1-MANJARO 
grub-reboot --version 
grub-reboot (GRUB) 2.06.r322.gd9b4638c5-1

no issues too

i hope this not coming from compiled GCC 12 , there was a report on kernel 5.19.3 about
Grub ( see grub.git - GNU GRUB)

on report archlinux , it seems to concern AMI Bios , not phoenix Bios ,
can we confirm that point ?