Issues with creating a dual-monitor hybrid graphics setup

Hi, I’m trying to make a dual monitor set up work where one card is plugged into the igpu and the other to a dgpu nvidia graphics card. On boot, the system loads modesetting for the igpu monitor as it should but the other monitor remains dead.

To start with, since it remains dead, xrandr can obviously not find the second monitor:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
HDMI-1 disconnected primary (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
DP-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94

which would be expected to be HDMI-1.
However inxi -G can detect both screens no problem (as can lspci but i won’t post it since it doesn’t really add any additional information (except maybe pci-IDs but i’ll post those later if necessary)):

  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU104 [GeForce RTX 2060] driver: N/A
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: modesetting
    gpu: i915 resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa

Now. inxi claims the driver for the nvidia card is N/A however running mhwd -li shows:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
     video-modesetting            2020.01.13                true            PCI

Which ought to be the appropriate driver according to mhwd -a pci nonfree 0300.
My /etc/X11/xorg.conf.d/90-mhwd.conf is empty and a new one wasn’t generated when i installed the driver, so I’m unsure of how to continue on that front since I’d like to avoid making a manual xorg-conf if at all possible (I’ve already had to fix the issues arising from doing that several times so I’d like to avoid having to do that again).

I have tried to run the bumblebee demon as well, however it doesn’t really seem to work stating:

bumblebeed[636]: No switching method available. The dedicated card will always be on.

I think that’s all the information on what i have going on and what I’ve tried. What is the appropriate way to resolve this issue in Manjaro?

As far as I know, Nvidia Optimus is not capable of using the internal graphics for one display and the dedicated graphics for another in parallel.
Optimus is designed for switching between internal and dedicated graphics to reduce the overall power consumption under changing workloads.

You should be able to run a dual monitor setup though.

Seems like the Nvidia driver Installation is messed up.

Right, so where should i go looking for the correct solution?

I tried updating my system and reinstalling the drivers with sudo mhwd -r video-hybrid-intel-nvidia-prime && sudo mhwd -i video-hybrid-intel-nvidia-prime and now inxi -G outputs:

  Device-1: Intel CoffeeLake-S GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU104 [GeForce RTX 2060] driver: nvidia v: 515.65.01
  Display: x11 server: X.Org v: 21.1.4 driver: X:
    loaded: modesetting,nvidia gpu: i915 resolution: 1: N/A 2: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA

So i tried enabling the screen, which for posterity i did by running:

xrandr --output {screen1name} --auto --output {screen2name} --auto &&
xrandr --output {screen1name} --auto --left-of {screen2name} --auto

and now it works.
Thank you for enlightening me on how bumblebee works though. I was in the completely wrong area

Nice, that you figured it out yourself!

BTW, bumblebee is not recommended as a switcher. Use either PRIME (as already installed) or optimus-manager.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.