Issues with booting Manjaro after install (GPU)

Hey guys, I have pretty weird issue with my attempt of dual booting Windows and Manjaro. So I have ancient GPU (Quadro FX 1800), on the install screen if I select open source drivers I get black screen with weird random colored pixels on it. When I select boot with proprietery drivers it works fine and installs Manjaro. The issue after the install when I try to boot it, I get the option from Manjaro to boot in either Windows or Manjaro and after I select that I get same black screen with random pixels just like when selecting boot with proprietery drivers. I have found some post about saying to try CTRL-ALT+(some F) so I tried all combinations and nothing reacts. Do you guys have any idea how I could boot into it?

Do any of these work? (runlevel 3 I would expect)

Once there we should be able to do things like

mhwd -li -l

Hey, thanks for quick response. I got it to boot fully using nomodeset. Below is result of that command.

`> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:2b:00.0 (0300:10de:0638) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

OK, can we also gather some general system information:

inxi -Fazy

From there we can also try to make sure of things
(mirrors, update, reinstall open drivers, rebuild initramfs, update-grub);

sudo pacman-mirrors -f && sudo pacman -Syu
sudo mhwd -f -i pci video-linux
sudo mkinitcpio -P && sudo update-grub

Reboot and check.

Just tried those commands and rebooted into same issue.

Edit: Trying [HowTo] get legacy 340xx NVIDIA drivers back right now

Here’s inxi -Fazy output

  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=c6e8d063-4d45-43e9-ade3-d75176de4baf rw nomodeset splash
    apparmor=1 security=apparmor udev.log_priority=3
  Desktop: GNOME v: 45.2 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0
    serial: <superuser required> UEFI: American Megatrends LLC. v: A.C0
    date: 03/06/2023
  Info: model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
    level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
    model-id: 0x21 (33) stepping: 2 microcode: 0xA20120A
  Topology: cpus: 1x cores: 12 tpc: 2 threads: 24 smt: enabled cache:
    L1: 768 KiB desc: d-12x32 KiB; i-12x32 KiB L2: 6 MiB desc: 12x512 KiB
    L3: 64 MiB desc: 2x32 MiB
  Speed (MHz): avg: 2516 high: 3700 min/max: 2200/4950 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 3700 2: 2200
    3: 2881 4: 2200 5: 2200 6: 2200 7: 3434 8: 2200 9: 2200 10: 2200 11: 2944
    12: 3004 13: 3222 14: 2200 15: 2880 16: 2200 17: 2200 18: 2200 19: 2200
    20: 2277 21: 2200 22: 2200 23: 2200 24: 3060 bogomips: 177654
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA G94GL [Quadro FX 1800] driver: N/A alternate: nouveau
    non-free: series: 340.xx status: legacy (EOL~2019-12-xx) last:
    release: 340.108 kernel: 5.4 xorg: 1.20 arch: Tesla process: 40-80nm
    built: 2006-2013 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 bus-ID: 2b:00.0
    chip-ID: 10de:0638 class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: X: loaded: modesetting alternate: fbdev,vesa
    dri: nouveau gpu: N/A display-ID: 0 note: no compositor data
  Monitor-1: Unknown-1 size-res: N/A modes: 1024x768
  API: EGL v: 1.5 platforms: device: 0 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast wayland: drv: swrast x11: drv: swrast
  API: OpenGL v: 4.5 vendor: mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: llvmpipe (LLVM 16.0.6 256 bits)
    device-ID: ffffffff:ffffffff memory: 61.25 GiB unified: yes
    display-ID: :0.0
  Device-1: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-2: Tenx USB AUDIO driver: hid-generic,snd-usb-audio,usbhid type: USB
    rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-5:3 chip-ID: 1130:1620
    class-ID: 0300
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
    v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 2a:00.0
    chip-ID: 10ec:8125 class-ID: 0200
  IF: enp42s0 state: down mac: <filter>
  Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-2.2:4
    chip-ID: 0a12:0001 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 989.25 GiB used: 11.24 GiB (1.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 5B2QGXA7 temp: 35.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: DataTraveler 3.0
    size: 57.73 GiB block-size: physical: 512 B logical: 512 B type: USB rev: 2.1
    spd: 480 Mb/s lanes: 1 mode: 2.0 tech: N/A serial: <filter> fw-rev: 0000
    scheme: MBR
  ID-1: / raw-size: 250 GiB size: 245.02 GiB (98.01%) used: 11.22 GiB (4.6%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 26.5 MiB (27.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 405 Uptime: 11m wakeups: 0 Memory: total: 64 GiB note: est.
  available: 62.72 GiB used: 3.36 GiB (5.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1179 libs: 323 tools: gnome-software,pamac
  pm: flatpak pkgs: 0 Shell: Zsh v: 5.9 running-in: gnome-terminal inxi: 3.3.31

Hey update on this, I have tried the link from my edit above. It gets a bit further showing the mobo logo and three loading dots and then freezes the screen, after few seconds it goes to black screen. I can’t even boot with nomodeset anymore. Adding the 3 to the end still works but the driver for the GPU is still N/A so -Fazy output seems to be the same as the one above.

For whatever its worth I might have said try earlier kernels but with the newer zen cpu you probably would prefer not.

If anything I would have expected a stale nvidia card to be supported by nouveau…
I suppose that makes me wonder if there is something else ‘in the way’…

1 Like

Plymouth is a boot screen intended to hide text during boot. It can often be more trouble than it’s worth.

The correct procedure to uninstall Plymouth can be found in the Manjaro Wiki Plymouth article, under the heading of REMOVAL.

Follow the procedure exactly, as there is more involved than a normal uninstall. When finished, reboot and see if this has resolved the booting issue.

I hope this helps. Cheers.

based on your mhwd -li output it seems that for whatever reason the free opensource drivers got installed. You can boot up your ISO once more and check in live session what driver got selected there for your card when choosing proprietary drivers. Then you can boot into your install and use mhwd again to install the working drivers.

Here some tutorials:

The card is too old to be provided any proprietary nvidia profile by mhwd.
(hence the users attempt to manually install 340xx)

hmm. there is also the mesa-amber branch for older cards. Amber Branch — The Mesa 3D Graphics Library latest documentation