Issues with Audio Assault plugins

Audio Assault plugins and software work just fine on Manjaro. I have run into an issue, though. Whenever a dialog window is supposed to pop up (for example as a file picker to import/export files) nothing happens, i.e. clicking the button on the plugin produces no effect. By the way, my DE is KDE. All required write permissions for the folders are correct.

I thought it was some sort of compatibility issue strictly related to Manjaro, as I have confirmation everything works fine under Ubuntu or Fedora, but here comes the weird part. I tried the plugins on another machine running the same Manjaro version and dialog windows did pop up! It must be something very specific related to my other machine (the one I do music production on) but I have no clue how to figure it out. I also tried with a new user to rule out any corrupt configuration: no luck.

Hope somone can help me troubleshoot this!

Personally i prefer in KDE Plasma to use
Can be set in ~.bash_profile or /etc/profile.d/ but not sure if in your case helps to have it or should be left to not being set or to be actually export GTK_USE_PORTAL=0

Tried both, nothing changes.

Probably then is not related with any of the GTk stuff, but rather the way and how the app is written, and what program language. Did you had a look at more dedicated forums for such software?