Issues running Python/GTK app under my user

So I’m trying to run an app that was made with Python/GTK. Running it under my user gives me all sorts of GTK errors, and eventually crashes when I open the Browse/path dialogue:

Gtk-Message: 21:34:46.140: Failed to load module "xapp-gtk3-module"
Gtk-Message: 21:34:46.140: Failed to load module "canberra-gtk-module"


(RimPy:10550): Gtk-WARNING **: 21:34:52.644: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognised image file format (gdk-pixbuf-error-quark, 3)
Bail out! Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognised image file format (gdk-pixbuf-error-quark, 3)
Aborted (core dumped)

Spoke with the developer of that app, and was suggested to check this thread: [SOLVED] Applications depending on GTK don't launch from terminal. / Newbie Corner / Arch Linux Forums

Checked whether XDG_DATA_DIRS and XDG_CONFIG_DIRS had the proper paths in them, and the former did but the latter did not. Set the latter in /etc/profile as export XDG_CONFIG_DIRS="/etc/xdg"
as per the wiki in that thread. I still experience the same issue, ever after restart (checked with echoing the variables)

After that I tried running the app under a different user (root in this case), and sure enough, it works as expected. So this could indicate there’s something misconfigured under my user that causes this.

Could anyone suggest where I should look next?

Thanks in advance~

If root can run app this is permission problem. One or more icon from your current theme isn’t readable by your user. Try change icon theme.

Thanks for the reply!

Changed my icon theme, but that didn’t help. Checked permissions under all the folders in the icon theme, but that didn’t show any permission issues from what I can tell.

Do you have special Python programs or libraries in your Path?
This seems like an upstream issue Redhat/Fedora: cannot be run because of missing · Issue #38 · rimpy-custom/RimPy · GitHub

You might better ask there.

(Testing under root is not good, you should use an actual other user.)

Thank you for the reply!

I’m fully aware of this and the security implications, but I gave it a shot regardless.
I’ve since tested it on another normal user (by logging in with the credentials in the DE), and with that other user I have the same issue as with mine, crashes at the Browse/path dialogue.

From what I know, no. Could you suggest how I could look into this?

I’m not sure, what does a RedHat or Fedora bug have to do with Manjaro? Although it’s true, that library is missing from the package at my end. But still, that would entail that the app shouldn’t run correctly as root, right?

Alright, I tried running some live sessions on various distros, and found out that only Manjaro live images seem to be affected by this. Tried these:

manjaro-xfce-21.2.6-minimal-220416-linux515 - App crashed, ran as root: works
manjaro-cinnamon-21.2.5-minimal-220314-linux515 - Same as above
debian-live-11.3.0-amd64-xfce - Works as expected
linuxmint-20.3-cinnamon-64bit - Same as above
cbpp-11.1-amd64-20210923 - Same as above
Fedora-Workstation-Live-x86_64-35-1.2 - Failed to boot on my machine for some reason

So, as that issue that @mithrial suggested stated, I tried to copy the loader files from another distro (from Debian’s deb package for libpixbuf), made sure they have the proper permissions (644+x, like the other two loader files), ran the app again, but still the same issue occurred. So I’m guessing either those loaders from Debian aren’t useable, or I need to compile them myself, or the solution lies somewhere else.

Could anyone suggest what I could try next, or how to build those loaders?

The package is Arch Linux - gdk-pixbuf2 2.42.8-1 (x86_64)
It lists libpng as a dependency so I guess it should be installed. Or else open a bug report with them.

However, as this is Manjaro, I don’t know if they accept it or of there’s an overlay/Manjaro-specific build.

It’s a Python program, so it could also be an issue with binding gtk and Python.

Any suggestions to where I could look into this?

Seems gdk-pixbuf2 is not in the Manjaro gitlab, so I’m guessing it’s not a specific build, will try to submit a bug report.

Now I have run into another problem, which is a bit embarrassing.

Not sure if it was caused by me mucking about with the icons when I tried to sort out this damn issue, of if this is an update issue (last time I had this Manjaro system on I did an update), but it seems all icons reverted back to the Adwaita theme.
Looking on the themes settings panel, only Adwaita, hicolor and hicontrast icon themes are present. I have tried to reinstall the Papirus and Manjaro default icon themes, but they don’t show up. They do show up with their own folder under /usr/share/icons however, and appear to be correctly installed by pacman.
Tried running the settings panel from the terminal to see if I get any additional output/errors on what’s going on, but nothing useful came up, except with some issues with some themes under the ~/.themes folder.
Tried renaming that folder to see if anything changes, but it’s the same issue.