Issues rebuilding audacious and deadbeef

I used audacious-git til today and i tried to recompile it. It fails. I’ve removed it and reinstalled audacious from repository and it doesn’t start anymore. It says:

ERROR plugin-init.cc:154 [start_required]: No interface plugin found.
(Did you forget to install audacious-plugins?) → No, i installed them.

Got build error with deadbeef too. Clementine doesn’t work too. I’ve got an error with some plugins missing, i can’t play an mp3 file… What’s happening? Strawberry works normally.

Errors building Deadbeef v1.8.8-3 have already been reported to AUR (en) - deadbeef
Version 1.8.8-2 is still working for me so I am waiting on release of v1.9.0

Audacious v4.1-3 from Manjaro extra repository has been working no problem since May 2021

Yet i’m getting this error. I’ve tried to reinstall it several times to no avail.
EDIT : cleared the configuration folder, now it works, but the gtk interface is not available on the build. Damn.

i’m using ready built package v1.8.8 from deadbeef developers, an it is still working;

https://sourceforge.net/projects/deadbeef/files/travis/linux/1.8.8/deadbeef-static-1.8.8-1-x86_64.pkg.tar.xz/download

deadbeef-git builds correctly, unlike audacious. The issue is likely related to ffmpeg being updated to 5.0.

I have fixed deadbeef yesterday https://aur.archlinux.org/cgit/aur.git/commit/?h=deadbeef&id=7ab3dbddb11d7ce95fd8f626ebb2a0ebbc97165f

1 Like

Good. Deadbeef fix already landed on git, no updates from audacious devs yet. A workaround has been made the by the aur package mantainer.
EDIT : audacious fix available on git.