Issues between kernels, disk and VMs (ignores vfio IDs?)

While I was trying to solve this issue, I tried few different kernels. As I am saying to my last answer, the issue is not there with kernel 5.10.79-1 LTS.

However, with 5.10 I am having two other issues:

  1. Boot, shutdown and reboot take much longer than with the others. After Grub, I am having a blank screen for around 20 seconds before I get to the login screen. Similar pattern is while restart/shutdown, where my secondary monitor turns blank, while my primary still displays everything for about 20 secs before actually reboots.

  2. A VM that I have, where I passthrough my VGA and one of my LAN adapters and works perfect with newer kernels, here ends with a kernel panic error.

I suspect that somehow it ignores the “vfio-pci.ids=1002:73bf,1002:ab28,1002:73a6,1002:73a4,10ec:8125” I have into kernel parameters and also the same IDs in “/etc/modprobe.d/vfio.conf” and the reason I am saying that is that under System Settings > Display, I have my passthrough VGA available and also under Network Settings my 2nd LAN adapter available too, while with the other kernels none of them are visible.

Why this is happening? I tried to update grub multiple times, but it didn’t help.
The only thing I change between boots is the kernel, nothing else.

Any help would be appreciated.

Ignore… Silly me…
For some reason, I haven’t run “mkinitcpio” for 5.10, although I usually run it with “-P” to build all available kernels.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.