Issues after Manjaro XFCE update

Hi Dear, Manjaro folk,

I wasn’t sure whether my issue was XFCE or Manjaro so I tried the forums at XFCE first (I find it easier to use), Issues after Manjaro XFCE update / Installation / Xfce Forums

Recently I updated. I finally had a chance to unlock the system to see how it went and I must admit the problems are unfortunately numerous.

First I was not able to unlock the PC from the lockscreen, there was a new error message that appeared. Something like “Authentication Failed”. No big loss, nothing unsaved, so I restarted from the lock screen menu.

Unfortunately, when I login after restarting:

1. The (typically bottom) panel is not present at all,
2. All the desktop icons are rearranged (they simply run down from the top left),
3. Attempting to click a desktop launcher file (to launch an application) a red error dialog with title “Launch error” and message in large letters, "Failed to run “programname.desktop”. The body of the error message states, “This feature requires a file manager service to be present (such as the one supplied by Thunar).” May seem minimally related to something that happened in 2021 and 2018/2019.
4. Clicking the ‘Rubbish’ and ‘Home’ icons on the desktop results in nothing.

Thankfully I was able to launch my browser from the command line to talk to folks here, but the above would be shocking for anyone who might not have that understanding.

Any help would be great.

It has been a few months since I last updated. The following output may help identify what went wrong:

:: Starting full system upgrade...
:: Replace at-spi2-atk with extra/at-spi2-core? [Y/n] y
:: Replace atk with extra/at-spi2-core? [Y/n] y
resolving dependencies...
looking for conflicting packages...
warning: dependency cycle detected:
warning: mesa will be installed before its libglvnd dependency
warning: dependency cycle detected:
warning: openimageio will be installed before its opencolorio dependency
warning: dependency cycle detected:
warning: lib32-mesa will be installed before its lib32-libglvnd dependency


:: Running pre-transaction hooks...
(1/4) Creating Timeshift snapshot before upgrade...
==> skipping timeshift-autosnap due skipRsyncAutosnap in /etc/timeshift-autosnap.conf set to TRUE.
(2/4) Removing linux initcpios...
(3/4) Remove Firefox Distribution Settings
(4/4) Removing old entries from the info directory file...
:: Processing package changes...
(1/2) removing at-spi2-atk
(2/2) removing atk                                               


() upgrading glibc
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
Generating locales...


() installing adwaita-cursors                            
() installing default-cursors
warning: /usr/share/icons/default/index.theme installed as /usr/share/icons/default/index.theme.pacnew
() installing db5.3
() installing qt5-imageformats
() installing http-parser
() installing libgit2
() installing ocl-icd
() installing libcamera
() installing pipewire
Created symlink /etc/systemd/user/ → /usr/lib/systemd/user/pipewire.socket.
() installing libwbclient
() installing gperftools
() installing highway
() installing libjxl
() installing nftables
() installing js102
() installing gcr-4
Created symlink /etc/systemd/user/ → /usr/lib/systemd/user/gcr-ssh-agent.socket.
() installing thunarx-python
() installing python-autocommand
() installing cython  
() installing python-typing_extensions
() installing python-pydantic
() installing python-inflect                                                         
() installing python-cssselect
() installing python-lxml
() installing python-numpy
() installing qca-qt5
() installing minizip-ng
() installing pybind11
() installing libaec
() installing hdf5
() installing openimageio
() installing openshadinglanguage
() upgrading lightdm 
warning: /etc/lightdm/lightdm.conf installed as /etc/lightdm/lightdm.conf.pacnew
() upgrading mkinitcpio
warning: /etc/mkinitcpio.conf installed as /etc/mkinitcpio.conf.pacnew
() installing foomatic-db-ppds
() installing foomatic-db-nonfree
Optional dependencies for foomatic-db-nonfree
    foomatic-db-nonfree-ppds: nonfree PPD files [pending]
() installing foomatic-db-nonfree-ppds
() installing elementary-icon-theme
:: Running post-transaction hooks...
( 1/35) Creating system user accounts...
Assertion 'fclose_nointr(f) != -EBADF' failed at src/basic/fd-util.c:128, function safe_fclose(). Aborting.
/usr/share/libalpm/scripts/systemd-hook: line 28: 345950 Aborted
(core dumped) /usr/bin/systemd-sysusers

After the above error it appears to continue on:

( 2/35) Updating journal message catalog...
( 3/35) Reloading system manager configuration...
( 4/35) Updating udev hardware database...
( 5/35) Applying kernel sysctl settings...
( 6/35) Creating temporary files...
( 7/35) Reloading device manager configuration...
( 8/35) Arming ConditionNeedsUpdate...
( 9/35) Updating the MIME type database...
(10/35) Updating fontconfig configuration...
(11/35) Rebuilding certificate stores...
(12/35) Updating module dependencies...
(13/35) Restoring locales
(14/35) Restarting cronie for libc upgrade...
(15/35) Updating linux initcpios...

There is more but its might be too much information for now.

Any ideas? Do I need to somehow retry step one???

1 Like

some of that sounds familiar: if you have dbus-x11 installed, remove and replace with dbus

1 Like

Thanks steanne, but that is not the problem in this case.

If anyone else has an idea, do please chime in.

@ToZ wrote:

Try creating a second user account and logging in through that account to see if things work better. Might help to see if its a system or profile issue.

I tried this and the new user also has the same issue.

The other major issue with XFCE 4.18 was:

If you click on the link above to go to the Stable Update Announcment, expand the arrow next to the libxfce4ui-nocsd text on that webpage. @philm did a nice job explaining the situation.

If you have libxfce4ui-nocsd installed, just install libxfce4ui and follow the prompts:

# search installed packages
pacman -Qs libxfce4ui
# install package
pacman -S libxfce4ui

Always read the Stable Update Annoucements, at least the first 2 posts. imho, only do an update after reading it.