Issues after last testing update

I apologize in advance, this may not be helpful however I thought I’d report it anyhow. I did not have time to figure out what was wrong. I needed to be up and running and couldn’t use my system in the state it was in so I timeshifted back, switched to stable branch and updated that way which has had no major issue since. So I am now off of Testing branch. But in case this helps I’ll report what little I know of it.

I had a major issue with this update. I performed the update on the night of the 9th. I couldn’t update initially because of the Playstation 2 emulator PCSX2. I installed the flatpak version of it and when I was satisfied I could run it I deleted the version from the repo which could not be updated due to a bug in the new version. That bug has already been reported on this forum by others and the solution seemed to be to hold off updates for it, this was causing a problem with wxgtk. I needed to delete wxgtk2 and a lib32 version connected to it before I could update. Having done all of this I updated.

After the update which seemed to be fine, or at least I didn’t immediately notice anything wrong, and was eager to get something done, so I launched Brave first thing after reboot. I was in the Brave browser and went to download a file when every drive immediately launched from nemo as well as two error messages from nemo trying to mount an external drive which was already mounted and possibly a blu-ray disc I had left in that drive.(I saw two messages, they could have both been for the external drive or one message for each)

I closed brave and started closing the multiple nemo windows that were now open(I have 8 internal drives and all but one are usually mounted at startup) I then clicked on nemo from the taskbar when done and it did the same thing, opening every drive and two error messages. I closed everything and was now on the desktop.

It was then that I noticed that my drives were not on the desktop. They normally are on the desktop as icons under Computer and Home. They are also normally in nemo on the left side of the file manager under ‘devices’ along with dvd or blu-ray drives or external drives or usb drives that are connected(or in the case of optical drives, ones which have a disc in them). Those were also missing. Devices was empty.

I now opened brave and started searching if some problem like this had been reported. I didn’t find anything. I then tried to start nemo in the terminal which did the same thing as before. I then tried with sudo and it opened normally but of course in super user mode.

So I closed nemo and the terminal and reopened the terminal and opened nemo normally again which again opened all of the windows. This time I looked for any error messages and saw one, unfortunately if I copied that error message I don’t know what I did with it.

I believe it was something to the effect of. GVFS-RemoteVolumeMonitor-WARNING owner of volume monitor something removing drives/mounts

I did a partial search on the GVFS-RemoteVolumeMonitor and didn’t find a solution to my problem. I then decided I had wasted too much of my time when I needed to be doing something else and I launched timeshift which I always use before I update.

Later on the next day I decided to switch back to stable branch and update that way. First I started by taking care of the PCSX2 issue again and this time I restarted the computer after I had deleted wxgtk2 and the lib32 one it was connected to and see if that was the cause of the issue before. No issue was found. I then updated to stable branch and haven’t had a major issue.

This might not be of much help but I am posting it none-the-less now that I have a bit of time.
I use Cinnamon desktop and Nemo file manager running Kernel 5.15 LTS. Maybe there is a bug, or maybe the update just got glitched.

  Host: james-manjaro Kernel: 5.15.59-1-MANJARO arch: x86_64 bits: 64
    Desktop: Cinnamon v: 5.4.9 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: CROSSHAIR VI HERO v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 7901
    date: 07/31/2020
  Info: 8-core AMD Ryzen 7 3700X [MT MCP] speed (MHz): avg: 2440
    min/max: 2200/4426
  Device-1: NVIDIA GA104 [GeForce RTX 3070] driver: nvidia v: 515.65.01
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 driver: X:
    loaded: nvidia gpu: nvidia resolution: 1920x1080~60Hz
  OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA
  Device-1: Intel I211 Gigabit Network driver: igb
  Local Storage: total: 18.19 TiB used: 9.7 TiB (53.3%)
  Processes: 405 Uptime: 1d 5h 49m Memory: 15.55 GiB used: 5.77 GiB (37.1%)
  Shell: fish inxi: 3.3.20