Issue with Snap Mount After Kernel Update - Loop Device Already in Use

Hello Manjaro Community,

I recently updated my system to kernel version 6.8.5-1-MANJARO and am now encountering an issue when trying to use Snap packages. The error occurs when I attempt to install or update Snap packages.

Error Message:

error: system does not fully support snapd: cannot mount squashfs image using "squashfs":
mount: /tmp/syscheck-mountpoint-2375228621: /dev/loop0 is already mounted or busy.
dmesg(1) might provide more information after a failed mount system call.

System Details:

  • Kernel Version: 6.8.5-1-MANJARO
  • Snap Version: 2.61.2
  • Affected Packages: Attempts to update/install Anydesk

Steps Taken to Troubleshoot:

  1. Checked and restarted snapd.
  2. Checked loop devices with losetup -a, found no active loop devices.
  3. Reinstalled snapd.
  4. Various kernel modules (including squashfs) have been checked and are loaded.

Despite these steps, the problem persists. I am wondering if the recent kernel update could be playing a role and whether anyone has had similar experiences or suggestions for resolving this issue.

Thank you in advance for any assistance or insights you can provide!

1 Like

What does it say?
dmesg | less
then scroll through using page up /page down - the arrow keys
journalctl --reverse
and go back in time the same way …

Can you not install and use an LTS kernel instead of what appears to be a very new one?

I do not use snaps and have zero experience with them.

KDE has got an app to view the systemd journal (the log) as well if I recall correctly.
But terminal output may be easier to obtain and possibly share.

1 Like

Hey, thanks for the quick reply. Well - I tried to switch back to the latest LTE Kernel and the Problem is gone. Not really sure whats the problem, I did not check the logs though.

Anyways, thanks for quick help. Topic can be closed.

It’ll close automatically after some time.
Or you can mark it as solved - one of the buttons in the bottom line of a post.

1 Like

I also have this issue. Isn’t marking it solved wrong thing, because the “supported” kernel is causing problems?

It’s apparently solved for him.

You may choose to investigate further.
It may depend on your hardware … or it may be a “known” problem with that kernel and snap, as @Yochanan just said.

I’d always choose the way that he chose - use what works.
Except when I’m curious. :man_shrugging:

Did you mean, LTS? :wink:

FYI, I’ve done a little research and Canonical does not seem to care that snapd is not working with 6.8.X. :man_shrugging:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.