Issue with Silicon Power A80 NVME SSD on Raspberry Pi 4b 4GB -- MSD Timeout, Won't Boot


I’m running into some frustration trying to boot off of a Silicon Power 1TB A80 NVME SSD (PCIe 3.0 x4): .

I’d previously been using a PCIe 4.0 NVME in the same USB-C enclosure (an Orico) with no issues, so I wasn’t expecting problems with this.

It won’t boot: I get an MSD Timeout, and no drive activity from the SSD. I have a vague suspicion it’s trying to draw too much power from the USB 3.0 plug on the Raspberry Pi, as this SSD actually lights up the blue activity light on the enclosure, which the previous SSD never did.

I was able to plug the SSD into another linux machine and get the SMART data off of it:

  1. I don’t see any obvious problems, but I also don’t know a whole lot about smartctl. Any issues leaping out to anyone?
  2. Could it really be the glowing light on the front giving me fits? Like I said, the drive that worked well did not make the light glow.
  3. If it’s an actual timeout of some kind–which I don’t think it is as I’ve watched it loop for minutes at a time looking for a boot volume–is there anything I can do about that aside from installing a bootloader on an SD card and using that to boot from the NVME? (e.g.: BerryBoot)
    I tried it with the 3.5A Canakit PSU and got the same result. I don’t know how to give it more power, unless I need to tell it to give more power to the USB ports specifically.
  4. I couldn’t boot whether the drive was plugged into the USB 2 or USB 3 ports.


ETA: Additional details about USB 2 + thoughts on glowy light.

smartctl 7.2 2020-12-30 r5155 [x86_64-linux-5.11.0-7633-generic] (local build)
Copyright (C) 2002-20, Bruce Allen, Christian Franke,

Model Number:                       SPCC M.2 PCIe SSD
Serial Number:                      $ITSaSECRETtoEVERYBODY
Firmware Version:                   ECFM32.1
PCI Vendor/Subsystem ID:            0x1987
IEEE OUI Identifier:                0x6479a7
Total NVM Capacity:                 1,024,209,543,168 [1.02 TB]
Unallocated NVM Capacity:           0
Controller ID:                      1
NVMe Version:                       1.3
Number of Namespaces:               1
Namespace 1 Size/Capacity:          1,024,209,543,168 [1.02 TB]
Namespace 1 Formatted LBA Size:     512
Namespace 1 IEEE EUI-64:            6479a7 4da0000154
Local Time is:                      Sat Sep  4 18:28:19 2021 CDT
Firmware Updates (0x12):            1 Slot, no Reset required
Optional Admin Commands (0x0017):   Security Format Frmw_DL Self_Test
Optional NVM Commands (0x005d):     Comp DS_Mngmt Wr_Zero Sav/Sel_Feat Timestmp
Log Page Attributes (0x08):         Telmtry_Lg
Maximum Data Transfer Size:         512 Pages
Warning  Comp. Temp. Threshold:     75 Celsius
Critical Comp. Temp. Threshold:     80 Celsius

Supported Power States
St Op     Max   Active     Idle   RL RT WL WT  Ent_Lat  Ex_Lat
 0 +    10.57W       -        -    0  0  0  0        0       0
 1 +     7.00W       -        -    1  1  1  1        0       0
 2 +     5.22W       -        -    2  2  2  2        0       0
 3 -   0.0490W       -        -    3  3  3  3     2000    2000
 4 -   0.0018W       -        -    4  4  4  4    25000   25000

Supported LBA Sizes (NSID 0x1)
Id Fmt  Data  Metadt  Rel_Perf
 0 +     512       0         2
 1 -    4096       0         1

SMART overall-health self-assessment test result: PASSED

SMART/Health Information (NVMe Log 0x02)
Critical Warning:                   0x00
Temperature:                        29 Celsius
Available Spare:                    100%
Available Spare Threshold:          5%
Percentage Used:                    0%
Data Units Read:                    32,816 [16.8 GB]
Data Units Written:                 2,374 [1.21 GB]
Host Read Commands:                 4,052,815
Host Write Commands:                26,592
Controller Busy Time:               0
Power Cycles:                       24
Power On Hours:                     1
Unsafe Shutdowns:                   11
Media and Data Integrity Errors:    0
Error Information Log Entries:      0
Warning  Comp. Temperature Time:    0
Critical Comp. Temperature Time:    0

Error Information (NVMe Log 0x01, 16 of 63 entries)
No Errors Logged
1 Like

I’ve done a lot more experimenting with this. I’ve determined two things with a high degree of certainty, and between those, I’m a bit stuck.

  1. For whatever reason, the Orico enclosure that worked fine before draws too much power from the Pi when using the Silicon Power NVME. I don’t understand this, or know how to fix it. I think I’m stuck.
  2. My powered USB 3.0 hub (Sabrent 4 port model) is unreliable with the Raspberry Pi. I’m very confused about this, as I bought this model because it was specifically recommended for use with the Pi, but with the hub plugged into AC power and no devices plugged in the hub, if I try to turn on the Pi it won’t even try to boot. I don’t even get any output to HDMI.

I did have it booting tonight, but then it stopped. I’m not sure what I did differently, except that I think I turned the Pi on with no media attached (no USB drive, no SD card), let it start looping, looking for a boot drive, then connected the hub while it was turned on and had the USB drive attached. I was even able to restart it without a problem, but then I had to unplug it and got back to square one.

I will try to confirm whether that works tomorrow. If that does work, it’s a ridiculous solution. It introduces an entire extra mess of wires and hardware to the already crammed area where the Pi is, and hardly seems stable.

smartctl looks fine but that’s all I can do for you as I’ve never experimented with any PI HW.