Issue with libpamac-flatpak-plugin Causing Pamac to Crash

Hello Manjaro Community,

I’ve encountered a persistent issue with Pamac where selecting the “Installed” tab caused the application to crash. After some troubleshooting, I found that the problem resolved when I uninstalled the libpamac-flatpak-plugin.

Here’s a detailed account of the situation:

The crash occurred every time I tried to view installed packages through Pamac.
Initially, I updated the system and cleared the Pacman cache, but the issue persisted.
I then tried to reinstall Pamac and its associated packages, yet the problem remained.
Upon removing the libpamac-flatpak-plugin, the problem ceased, and Pamac began to work normally, except for the lack of Flatpak support.

I currently have several Flatpak packages installed which I manage through the terminal, and I wonder if there’s an alternative way to integrate Flatpak support into Pamac without using the libpamac-flatpak-plugin.

Has anyone else experienced this issue, or does anyone have suggestions for an alternative method to manage Flatpak packages in Pamac without causing stability issues?

Any insights or feedback from the community would be greatly appreciated. If this is a known issue, I’m also interested in any ongoing efforts to address it.

Thank you for your assistance!

Can you please provide the exact package versions you’re using.

Edit /etc/pamac.conf and locate the line enabling AUR and change to


Save the file and run a full system update

sudo pacman-mirrors --continent && sudo pacman -Syu
1 Like

Did you mean /etc/pamac.conf? :wink:

Thanks to everyone for your replies!

@philm pamac-cli 11.6.0 - libpamac 11.6.3.

@linux-aarhus Fixed with: “sudo pacman-mirrors --continent && sudo pacman -Syu”

You’re all legends. Thanks for the epic save! :raised_hands:

Appreciate the thank you - I am just a human like you - a little more experienced - still a human.

1 Like

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.