Issue with comments section of articles on the BBC website using Brave browser


My system details:

[flex@thinkpad ~]$ cat /etc/lsb-release

My version of brave browser is from the Official Repositories (community):

[flex@thinkpad ~]$ pacman -Q | grep brave
brave-browser 1.45.133-1

Recently I started having a problem with brave browser in my Manjaro OS with KDE desktop. When I go to the comments section of articles on the BBC website… For instance this article is a problem for me right now.

I get this error message and I cannot post a comment only read comments from others.

On the other hand if instead I try the same link with the Vivaldi browser the comments section does work like this…

I asked about this on should I wait for help there or can I ask somewhere else as well? Stefano Capitani is the brave-browser packager for Manjaro. Would that chap know?

I’m just wondering who would I ask because I think the issue might be related to brave on Manjaro/Arch because I don’t have this problem with Brave in Windows 10.

I tried disabling extensions and with Shields down but that makes no difference. The comments section still gives that error when viewing it in Brave running on Manjaro. Also the problem is not because I am signed-out of the bbc website or because the article has been closed to comments.

Any help much appreciated.


I changed your topic title to better reflect your actual issue. :wink:

Have you tried other browsers to see if you can reproduce the issue?

The page is probably massively monitoring and tracking all your actions. Brave might block them which sometimes renders pages unusable.

Two options: Protect your privacy and don’t visit these pages.
(Or allow it in the options)

1 Like

I tried…
Vivaldi browser in Manjaro
Kiwi browser from my Pixel phone
Brave Browser in Windows 10
… and the BBC website comments section works fine in each of those browsers on those systems.

As I mentioned in my question the BBC comments section works fine in Brave Browser running on Windows 10 with full shields up and my (3) extensions enabled but running Brave in Manjaro even with shields down and extensions disabled I still have the problem.

I am wondering if this is a bug in the Manjaro/Arch version of Brave? That’s why I gave this thread the title it had originally because I am wondering is there somewhere in particular I should file a bug report for Brave-Browser Official Respository (community) that was downloaded using the Manjaro Add/Remove Software tool.

I would be very grateful if anyone would please check if the comments section in this article works for them in Brave in Manjaro OS with KDE desktop. I mean the version of Brave downloaded from Official Repositories. If the comments section in that article is closed to new comments then it would also be helpful to try any other article on the BBC website sports pages that have a comments section. None of them work in my Brave browser in Manjaro.



I got some advice from and I think the problem is now solved.

I simply logged out and logged back in to the site and now the comments sections are working again for me… using Brave in Manjaro with KDE desktop.



This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.