Issue with Accessing Dropbox Context Menu

Hello Manjaro Community,

I am currently experiencing a problem with my Dropbox application.

Dropbox is operating as expected for the most part - it syncs files properly and the Dropbox icon in my system tray accurately reflects the sync status, with the little blue icon appearing in the bottom right corner when the process is ongoing. However, the issue I am encountering is with accessing the Dropbox context menu.

Whenever I click on the Dropbox icon in the system tray, it does not open the context menu as expected. I have tried to troubleshoot this issue in the following ways, all to no avail:

  1. Installing Dropbox via the AUR.
  2. Installing Dropbox via Flatpak (from Flathub).
  3. Restarting my PC.
  4. Performing a complete re-installation of my Manjaro system.

For some additional context:

  • Occasionally, if I double-click the Dropbox icon multiple times in rapid succession, a context menu with a more old-fashioned appearance (white background, square shape) will flash on the screen for a fraction of a second. However, it disappears too quickly for me to interact with it, and it does not consistently appear, thus I can’t provide a screenshot.
  • Interestingly, once, using my current AUR installation, the context menu appeared in a more modern style, and it worked reliably for a short period of time. However, it reverted to the previous behaviour without any known change on my part.

I would greatly appreciate any guidance or suggestions you may have that could resolve this issue.

Thank you in advance for your help!