Issue mounting NTFS3 drive from fstab with new 6.4 kernel

I have a strange problem after update to 6.4 kernel.
I mount automatically an NTFS partition using ntfs3 driver.
It worked well before updating to 6.4 kernel but now it doesn’t.
If booting with 6.3 kernel and older there is no problem.
I have tried mounting the partition from command line and it works well when I dont use fstab but give all information in mount command

I have tried in fstab this

UUID=24EAB136EAB104D8 /mnt/Work ntfs3 defaults,exec,noacsrules 0 0

as well as this
/dev/sda1 /mnt/Work ntfs3 defaults,exec,noacsrules 0 0

Neither of which works. The error is always the same

mount: /mnt/Work: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.
dmesg(1) may have more information after failed mount system call.

But when I use

sudo mount -t ntfs3 /dev/sda1 /mnt/Work


sudo mount -t ntfs3 UUID=24EAB136EAB104D8 /mnt/Work

It works and the drive is mounted so I think it is not drivers problem.
dmsg does not show any information other than ntfs3 starting up (the first time) but no errors / warnings.

Has changed something that affects fstab mounting? I cant seem to find anything.
Thank you all in advance

Don’t know if it is a typing error but the good driver/module is ntfs-3g. Try switching as a first measure. Ntfs3 is worse driver, as far as i have read. Maybe the new kernel does not support if fully cause nobody uses it anyway… Just a hypothesis.

I have been working with it for some time now but I see that I should go back to the old driver.
Thank you

These mount options do not exist

Use this

 UUID=24EAB136EAB104D8 /mnt/Work  ntfs3   prealloc,uid=1000,gid=1000  0 0

I use ntfs3 and it works great

It is not the same thing.

NTFS-3G is a free GPL-licensed FUSE implementation of NTFS that was initially developed as a Linux kernel driver by Szabolcs Szakacsits. It was re-written as a FUSE program to work on other systems that FUSE supports and allows reading and writing to NTFS partitions.

Linux kernel versions 5.15 onwards carry NTFS3, a fully functional NTFS Read-Write driver which works on NTFS versions up to 3.1 and is maintained primarily by the Paragon Software Group.

One is a system driver, the other is integrated in the kernel and does not share the same code.

I have the same issue, Linux kernel 6.4 cannot mount NTFS 3 partitions.

However on Phoronix i found that Linux kernel 6.5 will have this issue resolved alongside performance improvements like:

Minor optimizations and fixes to the Paragon NTFS3 driver - fixes our issue here

Better NUMA awareness in the NFSD/RDMA server code - improved NUMA Support

Parallel CPU bring-up support - faster boot times

The Linux SLAB allocator is officially deprecated - better , more optimal resource management using SLUB if i understand the article correctly

The new cachestat system call - will handle and manage caches more efficiently

VirtIO sync object support for Vulkan - smoother or faster gaming on Linux

Enhanced load balancing for Intel hybrid CPUs - optimize multi-core and multi-thread load balancing

These are some of the chances and performance improvements intended for Kernel 6.5 but not all of them. There are other improvements i didn’t mention here.

For detailed reference:

I also use ntfs3 and it works great with kernel 6.4

UUID=189EE0749EE04BB6			   /Documents		  ntfs-3g defaults,nls=utf8,umask=000,dmask=027,fmask=137,uid=1000,gid=1000,windows_names 0 0

No you’re NOT.

literally one message above.

Sorry. But I thought these are different version of same driver. I am not a linux expert though.
What is the difference? Which is better and preferable?

You did not read previous message, I told you, yet you’re asking what has already been answered. Please read, click click above.

If you’re asking for my personal preference, I use NTFS3.