Iso9660 unable to mount

I found a bunch of old CDs from my grandma’s house that have a bunch of old family photos, but the computer that they used to make the CDs was a Windows computer. So now it seems that I cannot access them on my own Arch computer. The computer recognizes the CD and even the name, but every time I try to open it via Thunar file manager, it tells me “Error mounting /dev/sr0 at /run/media/user/Documents: Filesystem type iso9660 not configured in kernel…”.

Is there a way to overcome this, or should I just go ahead and toss the CDs 'cause they’re useless?

Have you by any chance updated the system and not rebooted?

No, I’ve updated and rebooted, I did so last night. I think there may be an issue with my kernel. Pacman reports that I have 1.15.133-3 installed, but uname reports that I am using 1.15.131-1.

Are you ~30 years in the past? :stuck_out_tongue: Anyway, that kernel never existed even back then.

Either way, fix whatever you did with kernels. You can also try 6.1 for example.

That’s the thing, I didn’t “do” anything to the kernel, I don’t even know how to. As far as I know, minus updates and a few extra packages installed via Pacman, my system is very “stock”. And either way, I suspect that the reason I cannot mount the CD is because I’m missing something that this kernel that I’m currently using either doesn’t have or doesn’t support. What are your thoughts? Retrieving these family pictures is especially important to my mom, any help would be appreciated.

Well I told you what you can try.

You can also load isofs module manually, but I don’t expect it to work.

modprobe isofs
modprobe: FATAL: Module isofs not found in directory /lib/modules/5.15.131-1-MANJARO

This is what the output was.

Reinstall kernel and/or install a different one. And reboot. That’s it.

EDIT: I wouldn’t be surprised if it actually worked if you rebooted “again”.

How? I genuinely don’t know how to do that.

You’re not up to date. The latest 5.15 kernel in the stable branch is currently 5.15.133-1.

Related kernel config for 5.15.133-1:

# CD-ROM/DVD Filesystems
# end of CD-ROM/DVD Filesystems

Note that m means that the device will not be compiled directly into the kernel, but loaded as a module.

I don’t expect it to work either because you didn’t run it with sudo. :wink:

@Tx86 Run the following to load it manually:

sudo modprobe isofs

To load it automatically, add it to a configuration file in /etc/modules-load.d/; i.e., /etc/modules-load.d/modules.conf:

# List of modules to load at boot
1 Like

I try to never write commands with sudo. IMHO, this is the mistake Manjaro wiki makes. And then some users are running everything with sudo, eg. mkdir in their home. Anyway, OP figured it out or else he would get “Operation not permitted.” :stuck_out_tongue:

You’re right, it worked. I used the GUI tool that comes with the settings manager, installed 6.1.55-1, and rebooted. Then ran modprobe isofs and boom, it magically started being able to actually access the disk. What I want to know is why did it work?

Why was my kernel so severely out of date? And why wasn’t isofs working with 5.15.131-1? and why was pacman saying that I had 1.15.133-1 installed, yet uname -r said that it was 1.15.131-1 that was actually running?

Should probably work without manually loading module as well. (I would think.)

That happens when you don’t reboot. And then old kernel is still loaded while there is new one installed with new modules. That is also the answer to why loading isofs (or any other module) isn’t working, no matter which kernel.

That’s so strange because I always reboot after I update my computer. The only thing I did this time was use the reboot button offered by xfce4-session-logout rather than typing sudo reboot after updating with pacman.

Because you didn’t actually load the module. I just went over that. :wink:

Then you’ll never successfully run commands that require it.

What mistake? Both the Arch and Manjaro wikis either preface commands with the $ (user) or # (root) prompt or specify the command must be run with sudo.

Obviously not. :roll_eyes:

:joy: Yes indeed. I meant when I type them as a text (eg. in this forum).

Yes, that seems logical thing to do. However compare:


Someone sees 100 sudos, and then just assumes it’s needed for everything. :stuck_out_tongue:

Sure did. :smiley:

When module actually exists and you try to load it:

❯ modprobe isofs
modprobe: ERROR: could not insert 'isofs': Operation not permitted

@zbe Please don’t be pedantic. The thread is now solved.

EDIT: Forgot to address:

Remember, wikis are community created and anyone can submit edits. Be the change you want to see.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.