ISO, Unable to set up partition table. sfdisk fails

I have been trying to install Manjaro on my old HP laptop. But without success.

I am able to boot using the USB. The installer can ‘see’ the 225GB Kingston SSD without any partition. It is a brand new disk.

Then it produces an error saying that it is unable to set up partition table.
sfdisk --wipe=always /dev/sda
fails

The BIOS has legacy support and secure boot, both, disabled.

Please let me know if we need additional information.

recheck that all disks are on AHCI under UEFI/bios

@stephane Thanks. Checked all BIOS options. There is no mention of AHCI. The installer also does not talk about AHCI. Is there a setting I have to do manually?

Have you created a partition table before installing?

@maycne.sonahoz No. It’s a store bought piece of hardware that went into the bay. I thought the installation process would take care of partitioning.

What do I do now?

If you choose the first option, i.e., to wipe a disk and automatic install, then the installer would take care of the partitioning, otherwise not.

@Shirshendu Thanks. I did choose that option. But it gave an error.

1 Like

Have you tried installing any other distro on that SSD?

1 Like

@Shirshendu Thanks. I have updated the question with more details about the error I encounter. And I am downloading Kubuntu to see if works :slight_smile:

1 Like

Well, you can try manually partitioning the disk [a /boot/efi partition with boot flag, a / partition with root flag, and swap and others if needed] to see if that works …

1 Like

AFAIK the installer will create the partitions, but not the partition table.
You should have a partitioning tool such as gparted bundled in the liveUSB for preparing the drive.

1 Like

@Shirshendu Thanks. But that did not work. Produced the same error.

@maycne.sonahoz Thanks. I used KDE partition editor to create partition table and a partition. That, too, failed.

2 Likes

Looks like some kind of bug in the new iso. I also tried to reinstall Manjaro to a SSD using the 21.2.4 KDE full and minimal iso. It gave the same error as @deshmukh though I had previously reinstalled Manjaro on that device 3-4 times, successfully.
Maybe @Manjaro-Team should take a look.

After a few trials and initially formatting the disk to ext4 and then launching calamares, somehow it worked… :person_shrugging:

5 Likes

Experiencing the same issue. Please @ishaanbhimwal sir, can you plz confirm if this crappy bug is on bare metal?

1 Like

A post was split to a new topic: What’s the exact moderator task here?