Iso not mounting

I am running KDE. I am trying to mount ISO. But it does nothing.

If I run lsblk. It shows me loop0 device. But dolphin file manager does nothing.
any solution? I am trying to mount ISO by gui not from terminal.
I tried gnomedisktool. It results same. loop0 device shows up. But nothing happens.

❯ lsblk -f
NAME   FSTYPE FSVER LABEL     UUID                                 FSAVAIL FSUSE% MOUNTPOINT
loop0                                                                             
sda                                                                               
├─sda1 vfat   FAT32 EFI       FFC7-CEC8                             498.7M     0% /boot/efi
└─sda2 ext4   1.0   System    be9daa15-3cb1-47a6-a06b-5a29c5a786d6   84.3G    18% /
sdb                                                                               
├─sdb1 ext4   1.0   Home      43d66661-eb4c-47c4-8c13-e4a5799715cf   84.6G     8% /home

I get this error in commandline 
❯ udisksctl loop-setup -r -f Win10_2004_English_x64.iso
Error setting up loop device for Win10_2004_English_x64.iso: GDBus.Error:org.freedesktop.UDisks2.Er
ror.Failed: Error waiting for loop object after creating '/dev/loop1': Timed out waiting for object

#################### inxi -Fxzc0 ########################

System:    Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: X550JK v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: X550JK v: 1.0 serial: <filter> UEFI: American Megatrends 
           v: X550JK.304 date: 04/16/2019 
Battery:   ID-1: BAT0 charge: 11.1 Wh condition: 11.2/32.6 Wh (35%) model: ASUSTeK X550A30 
           status: Not charging 
CPU:       Topology: Dual Core model: Intel Core i5-4200H bits: 64 type: MT MCP arch: Haswell 
           rev: 3 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22357 
           Speed: 2854 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 2794 2: 2794 3: 2794 
           4: 2794 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: ASUSTeK driver: i915 
           v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM107M [GeForce GTX 850M] vendor: ASUSTeK driver: nvidia v: 455.28 
           bus ID: 01:00.0 
           Device-3: Realtek USB Camera type: USB driver: uvcvideo bus ID: 1-7:5 
           Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia resolution: 
           1: 1366x768~60Hz 2: 1600x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2) v: 4.5 Mesa 20.1.8 
           direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel 
           v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
           driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:   Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter vendor: AzureWave 
           driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
           IF: wlp3s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK 
           driver: r8169 v: kernel port: d000 bus ID: 04:00.1 
           IF: enp4s0f1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.02 TiB used: 96.46 GiB (9.2%) 
           ID-1: /dev/sda vendor: Western Digital model: WDS120G2G0A-00JH30 size: 111.80 GiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
Partition: ID-1: / size: 109.06 GiB used: 19.18 GiB (17.6%) fs: ext4 dev: /dev/sda2 
           ID-2: /home size: 97.93 GiB used: 8.30 GiB (8.5%) fs: ext4 dev: /dev/sdb1 
Swap:      ID-1: swap-1 type: file size: 4.00 GiB used: 27.0 MiB (0.7%) file: /swapfile 
Sensors:   System Temperatures: cpu: 89.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 5000 
Info:      Processes: 270 Uptime: 3h 48m Memory: 7.66 GiB used: 3.63 GiB (47.4%) Init: systemd 
           Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 1419 Client: KDE Plasma v: 5.19.5 
           inxi: 3.1.05

Very often - such issues are caused by a missing reboot after a kernel update - please reboot and try again.

I have tried rebooting.

In that case I have no idea.

Manjaro usually has no problems with mounting an ISO so if it is not a reboot after kernel update?

Stupid question I know - but is your system fully up-to-date?

E.g. the konsole returns a message stating nothing to do when you run

sudo pacman -Syu

I have updated the kernel last week. My system is up to date.

Maybe try with Acetoneiso2