ISO loads to nonfunctional window

I have been using Manjaro-KDE successfully for approximately a year on a dual boot Acer Swift 3 laptop. I am trying to load the same OS, from the same DVD used previously (19.02-200311), to a new Acer Spin 5. It has Win10 installed (it works), with a 512 GB SSD and 16 GB RAM. I turned off secure boot, then used the Window disk management utility to free up about 440GB on the SSD.

My goal is a dual boot, and I’m following the instructions here: - supplemented by the instructions here:

I expected I could just use this validated ISO, run the updates, then I’d be set.

As the ISO is loading, I see two red FAILED messages:

The ISO loads to display the “Welcome to Manjaro” window, but the touchpad mouse is dead. In desperation, I plug in my Bluetooth Logitech mouse and suddenly I have a live mouse cursor. (The touchpad mouse works fine in Win10.)

Using my now-functional mouse I launch the installer from the “Welcome…” window. Fairly quickly, I see this:

I have no idea what to do at this point!

  1. Please use a newer ISO. Current version is 20.1
  2. You need a bigger drive for Manjaro as the installer says in your second screenshot. 30 GB is recommended as a minimum.

It’s not clear to me why an ISO about a year old would not work. Shouldn’t it?

As for drive space, as I stated, about 440GB is freed up on my SSD. I expected to set up partitioning once installation got under way. That how I always done it to this point. For the installer to fuss about space this early in the install process makes no sense to me. In any case, why cannot the installer see that free space on the SSD?

It might not be able to find the SSD. Windows could have updated some firmware on the SSD controller, making the old install media not able to see it.

It should, but it is obviously not.
So next step in troubleshooting, is to try a current ISO instead.

Okey. I’m on it. Thanks for your very rapid response. This forum is quite something!

Using a current ISO the mouse still is dead, but the Network Manager is working now. Relaunching the Installer - now “Mikah” - I’m still told there is not enough drive space, and there are no partitions.

Of course there are no partitions. I haven’t set them up yet, and the means to do that is part of the installer, if it would run.

I tried to launch the KDE partition manager from the menu - it’s there - but won’t launch. Very strange.

I’m open to new ideas, it’s after 2 AM here so I’ll sleep before I’m back. Thanks for your help to this point.

UPDATE: I just tried to create a dual boot system using a Fedora .iso. I ran into the same problems: no mouse at all (until I plugged in my USB Logitech mouse), and the 512GB SSD drive is nowhere to be seen.

I am frankly baffled by this, never having had this problem before when setting up a dual boot machine. Is the UEFI (about which I know very little) possibly blocking access to the SSD? How can I make this visible to my Linux live disks?

Do you know why software gets updated? (to fix bugs right?)
That’s why you always better use a recent/latest iso…
Just use the dd command to put the iso on a USB-Stick and boot with that, no need to create a CD/DVD.

When it comes to your SSD not being recognized, i would start with providing the output of sudo fdisk -l and sudo lsblk --fs on that system.
If the SSD is not shown in those outputs then you can be sure it is not recognized, else there is something else…

I did get a current ISO and posted about it (above). Couldn’t access the touchpad mouse and couldn’t see the SSD drive. I launched the KDS partition manager, and it couldn’t see the SSD drive either. Something is blocking it. This is something having to do with how Windows is set up I’m pretty sure.

I can’t believe other folks aren’t having this problem. This is a brand new Acer laptop. I’m going to contact them about this.

I don’t know what your level of expertise is with Linux or computers in general but what you wrote can mean a LOT of different things, so…

If you don’t provide what is asked of you by others, then you are left to fix your own problems…
Also see:

Thank you for your response.

If you don’t provide what is asked of you by others, then you are left to fix your own problems…

You are right, of course. I should have done that. It didn’t immediately strike me how I could do what you requested - then I realized that I could get a terminal from the live disk. By that time I had solved the SSD access problem.

Curiously, the solution came from a Fedora forum where I was working on the same problem, but with a Fedora ISO, because I seriously need to get this computer running with SOME decent Linux OS.

I was directed to a post in an Acer forum (!), where I found the solution in this comment -

Here’s the trick that solved the SSD drive visibility problem:
"SATA AHCI mode via CTRL+S while in the Main tab in BIOS "

But now I have a far different problem, and I’m starting a new thread for that.

Thank you for your responses and effort invested. These problems are seriously challenging for me and I appreciate greatly all your efforts to help!