Is tlp useful on a desktop - keyboard is being powered off

Does tlp provide any benefits for a desktop?

I’ve been experiencing problems with my usb keyboard. It is being powered off and it disappears from the system.

Rather than modify /etc/tlp.conf, I went the route of masking off the service. I’m using the long-term support kernel 5.4 on xfce 4.14.

PS: I tried to add a tag “tlp” by clicking the plus-sign, and it didn’t seem to do anything. And there wasn’t a tag for power management either.

In my personal opinion, there is no point to having TLP on a desktop computer. I have completely uninstalled it on mine. :wink:


Thank you. I like your direct solution :slight_smile:

Are there any other services or settings a Manjaro desktop user should review, that may have benefits for a laptop user, but not so much a desktop user. I know I usually look over Power Management settings.

Well, off the top of my head, I remember that I’ve also disabled (and masked) ModemManager and BlueTooth via systemctl. :wink:

I’m using tlp on desktops since 2015, it has a clear impact on vents.
In 2021, tlpui is a very simple and well explained GUI to fine tune.

I set my desktop to wake up from my USB keyboard (or double click on the mouse) so it doesn’t sleep too deeply until 12 hours later when it will wake up and put itself into hibernation… so that would really p#55 me off :laughing:

I did kill bluetooth too, and modemmanager because I’m on LAN, or WiFi via a plug in dongle, or nothing :stuck_out_tongue:

Me either.
In that case, it is also recommended to unload the pulseaudio bluetooth module because it does not appear to be needed and causes pulseaudio to spam the logs.

In order to accomplish that, create a file ~/.config/pulse/ with the following contents:

.include /etc/pulse/
unload-module module-suspend-on-idle
unload-module module-bluez5-discover

In my case, unloading module-suspend-on-idle was necessary as well, in order to avoid the speakers clicking each time before any audio playback started.

That file already exists on my system, but the module is not called as module-bluez5-discover; it is called as module-bluetooth-discover in my I have either way commented out the pertinent sections, as you can see below… :arrow_down:

### Automatically load driver modules for Bluetooth hardware
# .ifexists
# load-module module-bluetooth-policy
# .endif

# .ifexists
# load-module module-bluetooth-discover
# .endif

I do not have that problem here at my end.

If you edited /etc/pulse/, it may be possible that your edits get overwritten on the next update.
I already experienced such behavior with the linux510-nvidia390xx package which keeps overwriting /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf in a way that the X server is unable to find the Nvidia GLX module afterwards.

That’s why I created ~/.config/pulse/ instead, hoping that this file will be left untouched when updating Manjaro.

1 Like

Not normally, unless we’re talking of a major version upgrade of the package in question.

When pacman detects that a configuration file has been modified, it’ll store the new configuration file with a .pacnew suffix, and it is then up to the user to merge the two files.

In this case, I think a local configuration is preferable. Since starting with KDE I started being frustrated with Dolphin’s refusal to give me a root browser. I worked around it, but have learned that avoiding it is a better option… so I’ll go with the .config option :wink: Thanks for the tip.

The only time I get a click is a very quiet one when I unload Plex (as I disable pulse to run that) and it’s reassuring to hear it come back online.

According to my own experience, this does not always work.

Example: The file /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf gets overwritten each time linux510-nvidia390xx gets updated - without a *.pacnew file being written :frowning:

Another example: In order to get Qoppa PDF Studio to recognize my scanner that is connected via the network, I had to modify /usr/lib/systemd/system/saned@.service. See Sane: Share scanners via Network? - #5 by DAC324 for details.
This file gets overwritten on each update as well :frowning:

I had the lost keyboard problem occurring everytime the system was idle for some time. This started about a week ago.

I checked the update history in pamac and found that the 5.4 kernel was updated around that same time period:

[2021-01-17T17:43:04-0600] [ALPM] upgraded linux54 (5.4.80-2 → 5.4.85-1)

I installed the 5.10 kernel around 12 hours ago and let the system sit idle until now (about 12hrs, give or take):

[2021-01-23T16:10:16-0600] [ALPM] installed linux510 (5.10.7-3)

Fingers crossed, but the keyboard does not seem to be lost anymore.

It looks like something in the 5.4.85-1 update created a bug in the USB support in the kernel/drivers for the keyboard. No other USB devices seem to have been affected.